CVE-2022-36937
CVE-2022-36937
This page contains facts from public vulnerability sources. Check the original advisory before updating.
HHVM 4.172.0 and all prior versions use TLS 1.0 for secure connections when handling tls:// URLs in the stream extension. TLS1.0 has numerous published vulnerabilities and is deprecated. HHVM 4.153.4, 4.168.2, 4.169.2, 4.170.2, 4.171.1, 4.172.1, 4.173.0 replaces TLS1.0 with TLS1.3. Applications that call stream_socket_server or stream_socket_client functions with a URL starting with tls:// are affected.
CVSS 9.8 · Critical · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
hhvm
- Versions
- ≥ 4.172.0, < 4.172.1: Affected (semver)
- ≥ 4.171.0, < 4.171.1: Affected (semver)
- ≥ 4.170.0, < 4.170.2: Affected (semver)
- ≥ 4.169.0, < 4.169.2: Affected (semver)
- ≥ 4.154.0, < 1.168.2: Affected (semver)
- ≥ 0, < 4.153.4: Affected (semver)
Update to 4.153.4; Update to 4.169.2; Update to 4.170.2; Update to 4.171.1; Update to 4.172.1
hhvm Ubuntu:16.04:LTS
- Versions
- 3.11.0+dfsg-1
- 3.11.1+dfsg-1
- 3.11.1+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
hhvm Ubuntu:18.04:LTS
- Versions
- 3.21.0+dfsg-2
- 3.21.0+dfsg-2build1
- 3.21.0+dfsg-2build2
- 3.21.0+dfsg-2build3
- 3.21.0+dfsg-2ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published