CVE-2022-37155
CVE-2022-37155
This page contains facts from public vulnerability sources. Check the original advisory before updating.
RCE in SPIP 3.1.13 through 4.1.2 allows remote authenticated users to execute arbitrary code via the _oups parameter.
CVSS 8.8 · High · EPSS 40.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
spip Debian:13
- Affected ranges
- ECOSYSTEM: < 4.1.5+dfsg-1
Update to 4.1.5+dfsg-1
spip Debian:14
- Affected ranges
- ECOSYSTEM: < 4.1.5+dfsg-1
Update to 4.1.5+dfsg-1
spip Ubuntu:Pro:16.04:LTS
- Versions
- 3.0.20-1
- 3.0.21-1
- 3.0.21-1ubuntu1
- 3.0.21-1ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
spip Ubuntu:Pro:18.04:LTS
- Versions
- 3.1.4-3
- 3.1.4-4~deb9u3build0.18.04.1
- 3.1.4-4~deb9u5build0.18.04.1
- Affected ranges
- ECOSYSTEM: < 3.1.4-4~deb9u5ubuntu0.1~esm2
Update to 3.1.4-4~deb9u5ubuntu0.1~esm2
spip Ubuntu:22.04:LTS
- Versions
- 3.2.11-3
- 3.2.12-1
- 4.0.2-1
- 4.0.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://spawnzii.github.io/posts/2022/07/how-we-have-pwned-root-me-in-2022/
- https://blog.spip.net/Mise-a-jour-critique-de-securite-sortie-de-SPIP-4-1-5-SPIP-4-0-8-et-SPIP-3-2-16.html
- https://pastebin.com/ZH7CPc8X
- https://github.com/Abyss-W4tcher/ab4yss-wr4iteups/blob/ffa980faa9e3598d49d6fb7def4f7a67cfb5f427/SPIP%20-%20Pentest/SPIP%204.1.2/SPIP_4.1.2_AUTH_RCE/SPIP_4.1.2_AUTH_RCE_Abyss_Watcher_12_07_22.md
- https://nvd.nist.gov/vuln/detail/CVE-2022-37155