p PatchFirst

CVE-2022-37246

CVE-2022-37246

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Craft CMS 4.2.0.1 is affected by Cross Site Scripting (XSS) in the file src/web/assets/cp/src/js/BaseElementSelectInput.js and in specific on the line label: elementInfo.label.

CVSS 5.4 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • craftcms/cms Packagist

    Versions
    • 4.0.0
    • 4.0.0-RC1
    • 4.0.0-RC2
    • 4.0.0-RC3
    • 4.0.0.1
    • 4.0.1
    • 4.0.2
    • 4.0.3
    • 4.0.4
    • 4.0.5
    • 4.0.5.1
    • 4.0.5.2
    • 4.0.6
    • 4.1.0
    • 4.1.0.1
    • 4.1.0.2
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.1.4
    • 4.1.4.1
    • 4.2.0
    • 4.2.0.1
    • 4.2.0.2
    Affected ranges
    • ECOSYSTEM: ≥ 4.0.0-RC1, < 4.2.1

    Update to 4.2.1

  • craftcms/cms Packagist

    Versions
    • 3.7.39
    • 3.7.40
    • 3.7.40.1
    • 3.7.41
    • 3.7.42
    • 3.7.43
    • 3.7.44
    • 3.7.45
    • 3.7.45.1
    • 3.7.45.2
    • 3.7.46
    • 3.7.47
    • 3.7.47.1
    • 3.7.48
    • 3.7.49
    • 3.7.50
    Affected ranges
    • ECOSYSTEM: ≥ 3.7.39, < 3.7.51

    Update to 3.7.51

Original sources

Check your server →