CVE-2022-39285
CVE-2022-39285 · Stored Cross-Site Scripting Vulnerability In File Parameter in zoneminder
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ZoneMinder is a free, open source Closed-circuit television software application The file parameter is vulnerable to a cross site scripting vulnerability (XSS) by backing out of the current "tr" "td" brackets. This then allows a malicious user to provide code that will execute when a user views the specific log on the "view=log" page. This vulnerability allows an attacker to store code within the logs that will be executed when loaded by a legitimate user. These actions will be performed with the permission of the victim. This could lead to data loss and/or further exploitation including account takeover. This issue has been addressed in versions `1.36.27` and `1.37.24`. Users are advised to upgrade. Users unable to upgrade should disable database logging.
CVSS 7.6 · High · EPSS 5.1% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
zoneminder
- Versions
- < 1.36.27: Affected
- >= 1.37.0, < 1.37.24: Affected
No fix published
zoneminder Debian:12
- Affected ranges
- ECOSYSTEM: < 1.36.31+dfsg1-1
Update to 1.36.31+dfsg1-1
zoneminder Debian:13
- Affected ranges
- ECOSYSTEM: < 1.36.31+dfsg1-1
Update to 1.36.31+dfsg1-1
zoneminder Debian:14
- Affected ranges
- ECOSYSTEM: < 1.36.31+dfsg1-1
Update to 1.36.31+dfsg1-1
zoneminder Ubuntu:Pro:16.04:LTS
- Versions
- 1.28.1-8
- 1.29.0+dfsg-1
- 1.29.0+dfsg-1ubuntu1
- 1.29.0+dfsg-1ubuntu2
- 1.29.0+dfsg-1ubuntu2+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:Pro:20.04:LTS
- Versions
- 1.32.3-2build1
- 1.32.3-2ubuntu1
- 1.32.3-2ubuntu2
- 1.32.3-2ubuntu2+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:Pro:22.04:LTS
- Versions
- 1.36.7+dfsg1-1
- 1.36.10+dfsg1-1
- 1.36.11+dfsg1-1
- 1.36.12+dfsg1-1
- 1.36.12+dfsg1-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:24.04:LTS
- Versions
- 1.36.33+dfsg1-1build1
- 1.36.33+dfsg1-1build2
- 1.36.33+dfsg1-1build3
- 1.36.33+dfsg1-1build4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:25.10
- Versions
- 1.36.35+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:26.10
- Versions
- 1.36.37+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:26.04:LTS
- Versions
- 1.36.35+dfsg1-1
- 1.36.37+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/ZoneMinder/zoneminder/security/advisories/GHSA-h6xp-cvwv-q433
- https://github.com/ZoneMinder/zoneminder/commit/c0a4c05e84eea0f6ccf7169c014efe5422c9ba0d
- https://github.com/ZoneMinder/zoneminder/commit/d289eb48601a76e34feea3c1683955337b1fae59
- http://packetstormsecurity.com/files/171498/Zoneminder-Log-Injection-XSS-Cross-Site-Request-Forgery.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-39285