p PatchFirst

CVE-2022-39288

CVE-2022-39288 · Denial of service in Fastify via Content-Type header

This page contains facts from public vulnerability sources. Check the original advisory before updating.

fastify is a fast and low overhead web framework, for Node.js. Affected versions of fastify are subject to a denial of service via malicious use of the Content-Type header. An attacker can send an invalid Content-Type header that can cause the application to crash. This issue has been addressed in commit `fbb07e8d` and will be included in release version 4.8.1. Users are advised to upgrade. Users unable to upgrade may manually filter out http content with malicious Content-Type headers.

CVSS 7.5 · High · EPSS 59.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • fastify

    Versions
    • >= 4.0.0, < 4.8.1: Affected

    No fix published

  • fastify npm

    Affected ranges
    • SEMVER: ≥ 4.0.0, < 4.8.1

    Update to 4.8.1

Original sources

Check your server →