CVE-2022-39291
CVE-2022-39291 · Denial of service through logs in zoneminder
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ZoneMinder is a free, open source Closed-circuit television software application. Affected versions of zoneminder are subject to a vulnerability which allows users with "View" system permissions to inject new data into the logs stored by Zoneminder. This was observed through an HTTP POST request containing log information to the "/zm/index.php" endpoint. Submission is not rate controlled and could affect database performance and/or consume all storage resources. Users are advised to upgrade. There are no known workarounds for this issue.
CVSS 5.4 · Medium · EPSS 7.1% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
zoneminder
- Versions
- < 1.36.27: Affected
- >= 1.37.0, <1.37.24: Affected
No fix published
zoneminder Debian:12
- Affected ranges
- ECOSYSTEM: < 1.36.31+dfsg1-1
Update to 1.36.31+dfsg1-1
zoneminder Debian:13
- Affected ranges
- ECOSYSTEM: < 1.36.31+dfsg1-1
Update to 1.36.31+dfsg1-1
zoneminder Debian:14
- Affected ranges
- ECOSYSTEM: < 1.36.31+dfsg1-1
Update to 1.36.31+dfsg1-1
zoneminder Ubuntu:Pro:16.04:LTS
- Versions
- 1.28.1-8
- 1.29.0+dfsg-1
- 1.29.0+dfsg-1ubuntu1
- 1.29.0+dfsg-1ubuntu2
- 1.29.0+dfsg-1ubuntu2+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:Pro:20.04:LTS
- Versions
- 1.32.3-2build1
- 1.32.3-2ubuntu1
- 1.32.3-2ubuntu2
- 1.32.3-2ubuntu2+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:Pro:22.04:LTS
- Versions
- 1.36.7+dfsg1-1
- 1.36.10+dfsg1-1
- 1.36.11+dfsg1-1
- 1.36.12+dfsg1-1
- 1.36.12+dfsg1-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:24.04:LTS
- Versions
- 1.36.33+dfsg1-1build1
- 1.36.33+dfsg1-1build2
- 1.36.33+dfsg1-1build3
- 1.36.33+dfsg1-1build4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:25.10
- Versions
- 1.36.35+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:26.10
- Versions
- 1.36.37+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zoneminder Ubuntu:26.04:LTS
- Versions
- 1.36.35+dfsg1-1
- 1.36.37+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/ZoneMinder/zoneminder/security/advisories/GHSA-cfcx-v52x-jh74
- https://github.com/ZoneMinder/zoneminder/commit/34ffd92bf123070cab6c83ad4cfe6297dd0ed0b4
- https://github.com/ZoneMinder/zoneminder/commit/73d9f2482cdcb238506388798d3cf92546f9e40c
- https://github.com/ZoneMinder/zoneminder/commit/cb3fc5907da21a5111ae54128a5d0b49ae755e9b
- https://github.com/ZoneMinder/zoneminder/commit/de2866f9574a2bf2690276fad53c91d607825408
- http://packetstormsecurity.com/files/171498/Zoneminder-Log-Injection-XSS-Cross-Site-Request-Forgery.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-39291