p PatchFirst

CVE-2022-39297

CVE-2022-39297 · Deserialization of untrusted data in MelisCms

This page contains facts from public vulnerability sources. Check the original advisory before updating.

MelisCms provides a full CMS for Melis Platform, including templating system, drag'n'drop of plugins, SEO and many administration tools. Attackers can deserialize arbitrary data on affected versions of `melisplatform/melis-cms`, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication. Users should immediately upgrade to `melisplatform/melis-cms` >= 5.0.1. This issue was addressed by restricting allowed classes when deserializing user-controlled data.

CVSS 7.7 · High · EPSS 1.3% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • melis-cms

    Versions
    • <= 5.0.0: Affected

    No fix published

  • melisplatform/melis-cms Packagist

    Versions
    • v2.1
    • v2.1.1
    • v2.2.0
    • v2.2.1
    • v2.3.0
    • v2.3.1
    • v2.4.0
    • v2.5.0
    • v3.0.0
    • v3.0.1
    • v3.0.10
    • v3.0.2
    • v3.0.3
    • v3.0.4
    • v3.0.5
    • v3.0.6
    • v3.0.7
    • v3.0.8
    • v3.0.9
    • v3.1.0
    • v3.1.1
    • v3.1.10
    • v3.1.11
    • v3.1.12
    • v3.1.13
    • v3.1.2
    • v3.1.3
    • v3.1.4
    • v3.1.5
    • v3.1.6
    • v3.1.7
    • v3.1.8
    • v3.1.9
    • v3.2.0
    • v3.2.1
    • v3.2.10
    • v3.2.11
    • v3.2.12
    • v3.2.13
    • v3.2.14
    • v3.2.2
    • v3.2.3
    • v3.2.4
    • v3.2.5
    • v3.2.6
    • v3.2.7
    • v3.2.8
    • v3.2.9
    • v4.0.0
    • v4.0.1
    • v4.0.10
    • v4.0.11
    • v4.0.2
    • v4.0.3
    • v4.0.4
    • v4.0.5
    • v4.0.6
    • v4.0.7
    • v4.0.8
    • v4.0.9
    • v4.1.0
    • v4.1.1
    • v4.1.2
    • v5.0.0
    Affected ranges
    • ECOSYSTEM: < 5.0.1

    Update to 5.0.1

Original sources

Check your server →