p PatchFirst

CVE-2022-39313

CVE-2022-39313 · Parse Server crashes when receiving file download request with invalid byte range

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.

CVSS 7.5 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • parse-server

    Versions
    • < 4.10.17: Affected
    • >= 5.0.0, < 5.2.8: Affected

    No fix published

  • parse-server npm

    Affected ranges
    • SEMVER: < 4.10.17

    Update to 4.10.17

  • parse-server npm

    Affected ranges
    • SEMVER: ≥ 5.0.0, < 5.2.8

    Update to 5.2.8

Original sources

Check your server →