p PatchFirst

CVE-2022-39314

CVE-2022-39314 · User enumeration in the code-based login and password reset forms

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Kirby is a flat-file CMS. In versions prior to 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, Kirby is subject to user enumeration due to Improper Restriction of Excessive Authentication Attempts. This vulnerability affects you only if you are using the `code` or `password-reset` auth method with the `auth.methods` option or if you have enabled the `debug` option in production. By using two or more IP addresses and multiple login attempts, valid user accounts will lock, but invalid accounts will not, leading to account enumeration. This issue has been patched in versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1. If you cannot update immediately, you can work around the issue by setting the `auth.methods` option to `password`, which disables the code-based login and password reset forms.

CVSS 4.8 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • kirby

    Versions
    • >= 3.5.0, < 3.5.8.2: Affected
    • >= 2.6.0, < 3.6.6.2: Affected
    • >= 3.7.0, <3.7.5.1: Affected
    • >= 3.8.0, < 3.8.1: Affected

    No fix published

  • getkirby/cms Packagist

    Versions
    • 3.5.0
    • 3.5.1
    • 3.5.1-rc.1
    • 3.5.2
    • 3.5.2-rc.1
    • 3.5.3
    • 3.5.3.1
    • 3.5.4
    • 3.5.5
    • 3.5.5-rc.1
    • 3.5.6
    • 3.5.6-rc.1
    • 3.5.7
    • 3.5.7-rc.1
    • 3.5.7.1
    • 3.5.8
    • 3.5.8.1
    Affected ranges
    • ECOSYSTEM: ≥ 3.5.0, < 3.5.8.2

    Update to 3.5.8.2

  • getkirby/cms Packagist

    Versions
    • 3.6.0
    • 3.6.1
    • 3.6.1.1
    • 3.6.2
    • 3.6.2-rc.1
    • 3.6.2-rc.2
    • 3.6.2-rc.3
    • 3.6.3
    • 3.6.3-rc.1
    • 3.6.3-rc.2
    • 3.6.3.1
    • 3.6.4
    • 3.6.4-rc.1
    • 3.6.5
    • 3.6.5-rc.1
    • 3.6.6
    • 3.6.6-rc.1
    • 3.6.6.1
    Affected ranges
    • ECOSYSTEM: ≥ 3.6.0, < 3.6.6.2

    Update to 3.6.6.2

  • getkirby/cms Packagist

    Versions
    • 3.7.0
    • 3.7.0.1
    • 3.7.0.2
    • 3.7.1
    • 3.7.1-rc.1
    • 3.7.2
    • 3.7.2-rc.1
    • 3.7.2.1
    • 3.7.3
    • 3.7.3-rc.1
    • 3.7.4
    • 3.7.4-rc.1
    • 3.7.5
    Affected ranges
    • ECOSYSTEM: ≥ 3.7.0, < 3.7.5.1

    Update to 3.7.5.1

  • getkirby/cms Packagist

    Versions
    • 3.8.0
    • 3.8.1-rc.1
    Affected ranges
    • ECOSYSTEM: ≥ 3.8.0, < 3.8.1

    Update to 3.8.1

Original sources

Check your server →