CVE-2022-39315
CVE-2022-39315 · Kirby CMS vulnerable to user enumeration in the brute force protection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.
CVSS 6.5 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
kirby
- Versions
- < 3.5.8.2: Affected
- >= 3.6.0, < 3.6.6.2: Affected
- >= 3.7.0, < 3.7.5.1: Affected
- = 3.8.0: Affected
No fix published
getkirby/cms Packagist
- Versions
- 3.0.0
- 3.0.1
- 3.0.1-rc.1
- 3.0.2
- 3.0.2-rc.1
- 3.0.3
- 3.0.3-rc.1
- 3.0.3-rc.2
- 3.0.3-rc.3
- 3.1.0
- 3.1.0-rc.1
- 3.1.1
- 3.1.2
- 3.1.2-rc.1
- 3.1.3
- 3.1.3-rc.1
- 3.1.4
- 3.1.4-rc.1
- 3.2.0
- 3.2.0-rc.1
- 3.2.0-rc.2
- 3.2.0-rc.3
- 3.2.0-rc.4
- 3.2.1
- 3.2.1-rc.1
- 3.2.2
- 3.2.3
- 3.2.3-rc.1
- 3.2.4
- 3.2.4-rc.1
- 3.2.5
- 3.2.5-rc.1
- 3.2.5-rc.2
- 3.3.0
- 3.3.0-rc.1
- 3.3.0-rc.2
- 3.3.0-rc.3
- 3.3.0-rc.4
- 3.3.0-rc.5
- 3.3.1
- 3.3.1-rc.1
- 3.3.2
- 3.3.2-rc.1
- 3.3.3
- 3.3.3-rc.1
- 3.3.4
- 3.3.4-rc.1
- 3.3.5
- 3.3.5-rc.1
- 3.3.6
- 3.4.0
- 3.4.0-rc.1
- 3.4.0-rc.2
- 3.4.0-rc.3
- 3.4.1
- 3.4.1-rc.1
- 3.4.2
- 3.4.3
- 3.4.3-rc.1
- 3.4.4
- 3.4.4-rc.1
- 3.4.5
- 3.5.0
- 3.5.0-rc.1
- 3.5.0-rc.2
- 3.5.0-rc.3
- 3.5.0-rc.4
- 3.5.0-rc.5
- 3.5.0-rc.6
- 3.5.0-rc.7
- 3.5.1
- 3.5.1-rc.1
- 3.5.2
- 3.5.2-rc.1
- 3.5.3
- 3.5.3.1
- 3.5.4
- 3.5.5
- 3.5.5-rc.1
- 3.5.6
- 3.5.6-rc.1
- 3.5.7
- 3.5.7-rc.1
- 3.5.7.1
- 3.5.8
- 3.5.8.1
- Affected ranges
- ECOSYSTEM: < 3.5.8.2
Update to 3.5.8.2
getkirby/cms Packagist
- Versions
- 3.6.0
- 3.6.1
- 3.6.1.1
- 3.6.2
- 3.6.2-rc.1
- 3.6.2-rc.2
- 3.6.2-rc.3
- 3.6.3
- 3.6.3-rc.1
- 3.6.3-rc.2
- 3.6.3.1
- 3.6.4
- 3.6.4-rc.1
- 3.6.5
- 3.6.5-rc.1
- 3.6.6
- 3.6.6-rc.1
- 3.6.6.1
- Affected ranges
- ECOSYSTEM: ≥ 3.6.0, < 3.6.6.2
Update to 3.6.6.2
getkirby/cms Packagist
- Versions
- 3.7.0
- 3.7.0.1
- 3.7.0.2
- 3.7.1
- 3.7.1-rc.1
- 3.7.2
- 3.7.2-rc.1
- 3.7.2.1
- 3.7.3
- 3.7.3-rc.1
- 3.7.4
- 3.7.4-rc.1
- 3.7.5
- Affected ranges
- ECOSYSTEM: ≥ 3.7.0, < 3.7.5.1
Update to 3.7.5.1
getkirby/cms Packagist
- Versions
- 3.8.0
- 3.8.1-rc.1
- Affected ranges
- ECOSYSTEM: ≥ 3.8.0, < 3.8.1
Update to 3.8.1
Original sources
- https://github.com/getkirby/kirby/security/advisories/GHSA-c27j-76xg-6x4f
- https://github.com/getkirby/kirby/releases/tag/3.5.8.2
- https://github.com/getkirby/kirby/releases/tag/3.6.6.2
- https://github.com/getkirby/kirby/releases/tag/3.7.5.1
- https://github.com/getkirby/kirby/releases/tag/3.8.1
- https://nvd.nist.gov/vuln/detail/CVE-2022-39315