p PatchFirst

CVE-2022-39322

CVE-2022-39322 · @keystone-6/core vulnerable to field-level access-control bypass for multiselect field

This page contains facts from public vulnerability sources. Check the original advisory before updating.

@keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their `multiselect` fields to use the field-level access control - if configured - are vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than `multiselect` are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the `multiselect` field.

CVSS 9.1 · Critical · EPSS 1.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • keystone

    Versions
    • >= 2.2.0, < 2.3.1: Affected

    No fix published

  • @keystone-6/core npm

    Affected ranges
    • SEMVER: ≥ 2.2.0, < 2.3.1

    Update to 2.3.1

Original sources

Check your server →