CVE-2022-3970
CVE-2022-3970 · LibTIFF tif_getimage.c TIFFReadRGBATileExt integer overflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was found in LibTIFF. It has been classified as critical. This affects the function TIFFReadRGBATileExt of the file libtiff/tif_getimage.c. The manipulation leads to integer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The name of the patch is 227500897dfb07fb7d27f7aa570050e62617e3be. It is recommended to apply a patch to fix this issue. The identifier VDB-213549 was assigned to this vulnerability.
CVSS 6.3 · Medium · EPSS 1.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libtiff
- Versions
- n/a: Affected
No fix published
tiff Debian:12
- Affected ranges
- ECOSYSTEM: < 4.4.0-6
Update to 4.4.0-6
tiff Debian:13
- Affected ranges
- ECOSYSTEM: < 4.4.0-6
Update to 4.4.0-6
tiff Debian:14
- Affected ranges
- ECOSYSTEM: < 4.4.0-6
Update to 4.4.0-6
tiff Ubuntu:Pro:14.04:LTS
- Versions
- 4.0.2-4ubuntu3
- 4.0.3-5ubuntu1
- 4.0.3-6
- 4.0.3-6ubuntu1
- 4.0.3-7
- 4.0.3-7ubuntu0.1
- 4.0.3-7ubuntu0.2
- 4.0.3-7ubuntu0.3
- 4.0.3-7ubuntu0.4
- 4.0.3-7ubuntu0.6
- 4.0.3-7ubuntu0.7
- 4.0.3-7ubuntu0.8
- 4.0.3-7ubuntu0.9
- 4.0.3-7ubuntu0.10
- 4.0.3-7ubuntu0.11
- 4.0.3-7ubuntu0.11+esm1
- 4.0.3-7ubuntu0.11+esm2
- 4.0.3-7ubuntu0.11+esm3
- 4.0.3-7ubuntu0.11+esm4
- 4.0.3-7ubuntu0.11+esm5
- Affected ranges
- ECOSYSTEM: < 4.0.3-7ubuntu0.11+esm6
Update to 4.0.3-7ubuntu0.11+esm6
tiff Ubuntu:Pro:16.04:LTS
- Versions
- 4.0.3-12.3ubuntu2
- 4.0.5-1
- 4.0.6-1
- 4.0.6-1ubuntu0.1
- 4.0.6-1ubuntu0.2
- 4.0.6-1ubuntu0.3
- 4.0.6-1ubuntu0.4
- 4.0.6-1ubuntu0.5
- 4.0.6-1ubuntu0.6
- 4.0.6-1ubuntu0.7
- 4.0.6-1ubuntu0.8
- 4.0.6-1ubuntu0.8+esm1
- 4.0.6-1ubuntu0.8+esm2
- 4.0.6-1ubuntu0.8+esm3
- 4.0.6-1ubuntu0.8+esm4
- 4.0.6-1ubuntu0.8+esm6
- 4.0.6-1ubuntu0.8+esm7
- Affected ranges
- ECOSYSTEM: < 4.0.6-1ubuntu0.8+esm8
Update to 4.0.6-1ubuntu0.8+esm8
tiff Ubuntu:18.04:LTS
- Versions
- 4.0.8-5
- 4.0.8-6
- 4.0.9-1
- 4.0.9-2
- 4.0.9-3
- 4.0.9-4
- 4.0.9-4ubuntu1
- 4.0.9-5
- 4.0.9-5ubuntu0.1
- 4.0.9-5ubuntu0.2
- 4.0.9-5ubuntu0.3
- 4.0.9-5ubuntu0.4
- 4.0.9-5ubuntu0.5
- 4.0.9-5ubuntu0.6
- 4.0.9-5ubuntu0.7
- 4.0.9-5ubuntu0.8
- Affected ranges
- ECOSYSTEM: < 4.0.9-5ubuntu0.9
Update to 4.0.9-5ubuntu0.9
tiff Ubuntu:20.04:LTS
- Versions
- 4.0.10+git191003-1
- 4.1.0+git191117-1
- 4.1.0+git191117-2
- 4.1.0+git191117-2build1
- 4.1.0+git191117-2ubuntu0.20.04.1
- 4.1.0+git191117-2ubuntu0.20.04.2
- 4.1.0+git191117-2ubuntu0.20.04.3
- 4.1.0+git191117-2ubuntu0.20.04.4
- 4.1.0+git191117-2ubuntu0.20.04.5
- 4.1.0+git191117-2ubuntu0.20.04.6
- Affected ranges
- ECOSYSTEM: < 4.1.0+git191117-2ubuntu0.20.04.7
Update to 4.1.0+git191117-2ubuntu0.20.04.7
tiff Ubuntu:22.04:LTS
- Versions
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.0-3build1
- 4.3.0-4
- 4.3.0-5
- 4.3.0-6
- 4.3.0-6ubuntu0.1
- 4.3.0-6ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 4.3.0-6ubuntu0.3
Update to 4.3.0-6ubuntu0.3
Original sources
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=53137
- https://oss-fuzz.com/download?testcase_id=5738253143900160
- https://gitlab.com/libtiff/libtiff/-/commit/227500897dfb07fb7d27f7aa570050e62617e3be
- https://vuldb.com/?id.213549
- https://security.netapp.com/advisory/ntap-20221215-0009/
- https://lists.debian.org/debian-lts-announce/2023/01/msg00018.html
- https://support.apple.com/kb/HT213843
- https://support.apple.com/kb/HT213841
- https://nvd.nist.gov/vuln/detail/CVE-2022-3970