CVE-2022-40313
CVE-2022-40313
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to load.
CVSS 7.1 · High · EPSS 0.7% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- 4.0 to 4.0.3, 3.11 to 3.11.9, 3.9 to 3.9.16 and earlier unsupported versions: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.9.0
- v3.9.0-beta
- v3.9.0-rc1
- v3.9.0-rc2
- v3.9.0-rc3
- v3.9.1
- v3.9.10
- v3.9.11
- v3.9.12
- v3.9.13
- v3.9.14
- v3.9.15
- v3.9.16
- v3.9.2
- v3.9.3
- v3.9.4
- v3.9.5
- v3.9.6
- v3.9.7
- v3.9.8
- v3.9.9
- Affected ranges
- ECOSYSTEM: ≥ 3.9, < 3.9.17
Update to 3.9.17
moodle/moodle Packagist
- Versions
- v3.11.0
- v3.11.0-beta
- v3.11.0-rc1
- v3.11.0-rc2
- v3.11.1
- v3.11.2
- v3.11.3
- v3.11.4
- v3.11.5
- v3.11.6
- v3.11.7
- v3.11.8
- v3.11.9
- Affected ranges
- ECOSYSTEM: ≥ 3.11, < 3.11.10
Update to 3.11.10
moodle/moodle Packagist
- Versions
- v4.0.0
- v4.0.0-beta
- v4.0.0-rc1
- v4.0.0-rc2
- v4.0.0-rc3
- v4.0.0-rc4
- v4.0.1
- v4.0.2
- v4.0.3
- Affected ranges
- ECOSYSTEM: ≥ 4.0, < 4.0.4
Update to 4.0.4
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published