CVE-2022-40743
CVE-2022-40743 · Apache Traffic Server: Security issues with the xdebug plugin
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Input Validation vulnerability for the xdebug plugin in Apache Software Foundation Apache Traffic Server can lead to cross site scripting and cache poisoning attacks.This issue affects Apache Traffic Server: 9.0.0 to 9.1.3. Users should upgrade to 9.1.4 or later versions.
CVSS 6.1 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache traffic server
- Versions
- ≥ 9.0.0, ≤ 9.1.3: Affected (custom)
No fix published
trafficserver Debian:12
- Affected ranges
- ECOSYSTEM: < 9.1.4+ds-1
Update to 9.1.4+ds-1
trafficserver Ubuntu:16.04:LTS
- Versions
- 5.3.0-2ubuntu1
- 5.3.0-2ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
trafficserver Ubuntu:18.04:LTS
- Versions
- 7.0.0-5
- 7.1.2+ds-2
- 7.1.2+ds-2build1
- 7.1.2+ds-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
trafficserver Ubuntu:Pro:20.04:LTS
- Versions
- 8.0.5+ds-1
- 8.0.5+ds-2
- 8.0.5+ds-2build1
- 8.0.5+ds-2ubuntu1
- 8.0.5+ds-3
- 8.0.5+ds-3ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
trafficserver Ubuntu:Pro:22.04:LTS
- Versions
- 8.1.1+ds-1.1
- 9.1.1+ds-2build1
- 9.1.1+ds-2ubuntu0.1~esm1
- 9.1.1+ds-2ubuntu0.1
- 9.1.1+ds-2ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published