CVE-2022-40898
CVE-2022-40898
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue discovered in Python Packaging Authority (PyPA) Wheel 0.37.1 and earlier allows remote attackers to cause a denial of service via attacker controlled input to wheel cli.
CVSS 7.5 · High · EPSS 2.8% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wheel Debian:12
- Affected ranges
- ECOSYSTEM: < 0.38.0-1
Update to 0.38.0-1
wheel Debian:13
- Affected ranges
- ECOSYSTEM: < 0.38.0-1
Update to 0.38.0-1
wheel Debian:14
- Affected ranges
- ECOSYSTEM: < 0.38.0-1
Update to 0.38.0-1
wheel PyPI
- Versions
- 0.1
- 0.10.0
- 0.10.1
- 0.10.2
- 0.10.3
- 0.11.0
- 0.12.0
- 0.13.0
- 0.14.0
- 0.15.0
- 0.16.0
- 0.17.0
- 0.18.0
- 0.19.0
- 0.2
- 0.21.0
- 0.22.0
- 0.23.0
- 0.24.0
- 0.25.0
- 0.26.0
- 0.27.0
- 0.28.0
- 0.29.0
- 0.3
- 0.30.0
- 0.30.0a0
- 0.31.0
- 0.31.1
- 0.32.0
- 0.32.1
- 0.32.2
- 0.32.3
- 0.33.0
- 0.33.1
- 0.33.4
- 0.33.5
- 0.33.6
- 0.34.0
- 0.34.1
- 0.34.2
- 0.35.0
- 0.35.1
- 0.36.0
- 0.36.1
- 0.36.2
- 0.37.0
- 0.37.1
- 0.38.0
- 0.4
- 0.4.1
- 0.4.2
- 0.5
- 0.6
- 0.7
- 0.8
- 0.9
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 0.9.7
- Affected ranges
- ECOSYSTEM: < 0.38.1
Update to 0.38.1
python-pip Ubuntu:Pro:14.04:LTS
- Versions
- 1.4.1-2
- 1.5.4-1
- 1.5.4-1ubuntu1
- 1.5.4-1ubuntu3
- 1.5.4-1ubuntu4
- 1.5.4-1ubuntu4+esm1
- 1.5.4-1ubuntu4+esm2
- Affected ranges
- ECOSYSTEM: < 1.5.4-1ubuntu4+esm3
Update to 1.5.4-1ubuntu4+esm3
wheel Ubuntu:Pro:14.04:LTS
- Versions
- 0.24.0-1~ubuntu1
- 0.24.0-1~ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 0.24.0-1~ubuntu1.1+esm1
Update to 0.24.0-1~ubuntu1.1+esm1
python-pip Ubuntu:Pro:16.04:LTS
- Versions
- 1.5.6-7ubuntu1
- 1.5.6-7ubuntu2
- 8.0.2-7
- 8.0.3-1
- 8.0.3-2
- 8.1.0-1
- 8.1.0-2
- 8.1.1-1
- 8.1.1-2
- 8.1.1-2ubuntu0.1
- 8.1.1-2ubuntu0.2
- 8.1.1-2ubuntu0.4
- 8.1.1-2ubuntu0.6
- 8.1.1-2ubuntu0.6+esm2
- 8.1.1-2ubuntu0.6+esm3
- Affected ranges
- ECOSYSTEM: < 8.1.1-2ubuntu0.6+esm4
Update to 8.1.1-2ubuntu0.6+esm4
wheel Ubuntu:Pro:16.04:LTS
- Versions
- 0.26.0-1
- 0.29.0-1
- Affected ranges
- ECOSYSTEM: < 0.29.0-1ubuntu0.1~esm1
Update to 0.29.0-1ubuntu0.1~esm1
python-pip Ubuntu:18.04:LTS
- Versions
- 9.0.1-2
- 9.0.1-2.3~ubuntu1
- 9.0.1-2.3~ubuntu1.18.04.1
- 9.0.1-2.3~ubuntu1.18.04.2
- 9.0.1-2.3~ubuntu1.18.04.3
- 9.0.1-2.3~ubuntu1.18.04.4
- 9.0.1-2.3~ubuntu1.18.04.5
- 9.0.1-2.3~ubuntu1.18.04.6
- Affected ranges
- ECOSYSTEM: < 9.0.1-2.3~ubuntu1.18.04.7
Update to 9.0.1-2.3~ubuntu1.18.04.7
wheel Ubuntu:18.04:LTS
- Versions
- 0.29.0-2
- 0.30.0-0.2
- Affected ranges
- ECOSYSTEM: < 0.30.0-0.2ubuntu0.1
Update to 0.30.0-0.2ubuntu0.1
python-pip Ubuntu:20.04:LTS
- Versions
- 18.1-5
- 18.1-5build1
- 18.1-5ubuntu1
- 20.0.2-2
- 20.0.2-4
- 20.0.2-5
- 20.0.2-5ubuntu1
- 20.0.2-5ubuntu1.1
- 20.0.2-5ubuntu1.3
- 20.0.2-5ubuntu1.4
- 20.0.2-5ubuntu1.5
- 20.0.2-5ubuntu1.6
- 20.0.2-5ubuntu1.7
- Affected ranges
- ECOSYSTEM: < 20.0.2-5ubuntu1.8
Update to 20.0.2-5ubuntu1.8
wheel Ubuntu:20.04:LTS
- Versions
- 0.32.3-2
- 0.33.6-1
- 0.33.6-1ubuntu1
- 0.33.6-2
- 0.34.2-1
- Affected ranges
- ECOSYSTEM: < 0.34.2-1ubuntu0.1
Update to 0.34.2-1ubuntu0.1
python-pip Ubuntu:22.04:LTS
- Versions
- 20.3.4-4
- 21.3.1+dfsg-3
- 22.0.2+dfsg-1
- 22.0.2+dfsg-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 22.0.2+dfsg-1ubuntu0.2
Update to 22.0.2+dfsg-1ubuntu0.2
wheel Ubuntu:22.04:LTS
- Versions
- 0.34.2-1
- 0.37.1-2
- Affected ranges
- ECOSYSTEM: < 0.37.1-2ubuntu0.22.04.1
Update to 0.37.1-2ubuntu0.22.04.1