CVE-2022-4202
CVE-2022-4202 · GPAC lsr_dec.c lsr_translate_coords integer overflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability, which was classified as problematic, was found in GPAC 2.1-DEV-rev490-g68064e101-master. Affected is the function lsr_translate_coords of the file laser/lsr_dec.c. The manipulation leads to integer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. The name of the patch is b3d821c4ae9ba62b3a194d9dcb5e99f17bd56908. It is recommended to apply a patch to fix this issue. VDB-214518 is the identifier assigned to this vulnerability.
CVSS 6.3 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gpac
- Versions
- 2.1-DEV-rev490-g68064e101-master: Affected
No fix published
gpac Debian:11
- Versions
- 1.0.1+dfsg1-4
- 1.0.1+dfsg1-4+deb11u1
- Affected ranges
- ECOSYSTEM: < 1.0.1+dfsg1-4+deb11u2
Update to 1.0.1+dfsg1-4+deb11u2
gpac Ubuntu:Pro:14.04:LTS
- Versions
- 0.5.0+svn4288~dfsg1-1ubuntu1
- 0.5.0+svn4288~dfsg1-4
- 0.5.0+svn4288~dfsg1-4ubuntu1
- 0.5.0+svn4288~dfsg1-4ubuntu1+esm1
- 0.5.0+svn4288~dfsg1-4ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:16.04:LTS
- Versions
- 0.5.2-426-gc5ad4e4+dfsg5-1build1
- 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1
- 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:18.04:LTS
- Versions
- 0.5.2-426-gc5ad4e4+dfsg5-3
- 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1
- 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:20.04:LTS
- Versions
- 0.5.2-426-gc5ad4e4+dfsg5-4ubuntu1
- 0.5.2-426-gc5ad4e4+dfsg5-5
- 0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:22.04:LTS
- Versions
- 1.0.1+dfsg1-4
- 1.0.1+dfsg1-5
- 2.0.0+dfsg1-2
- 2.0.0+dfsg1-2ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:24.04:LTS
- Versions
- 2.2.1+dfsg1-3
- 2.2.1+dfsg1-3.1
- 2.2.1+dfsg1-3.1build1
- 2.2.1+dfsg1-3.1build2
- 2.2.1+dfsg1-3.1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://drive.google.com/file/d/1HVWa6IpAbvsMS5rx091RfjUB4GfXrMLE/view
- https://vuldb.com/?id.214518
- https://github.com/gpac/gpac/issues/2333
- https://github.com/gpac/gpac/commit/b3d821c4ae9ba62b3a194d9dcb5e99f17bd56908
- https://www.debian.org/security/2023/dsa-5411
- https://nvd.nist.gov/vuln/detail/CVE-2022-4202