p PatchFirst

CVE-2022-4223

CVE-2022-4223

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The pgAdmin server includes an HTTP API that is intended to be used to validate the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. The utility is executed by the server to determine what PostgreSQL version it is from. Versions of pgAdmin prior to 6.17 failed to properly secure this API, which could allow an unauthenticated user to call it with a path of their choosing, such as a UNC path to a server they control on a Windows machine. This would cause an appropriately named executable in the target path to be executed by the pgAdmin server.

CVSS 8.8 · High · EPSS 80.1% · Public exploit · Fix available

Published
Updated

Stack: python

Affected products and versions

  • pgadmin4

    Versions
    • pgadmin4 6.17: Affected

    No fix published

  • pgadmin4 PyPI

    Versions
    • 4.20
    • 4.22
    • 4.23
    • 4.24
    • 4.25
    • 4.26
    • 4.27
    • 4.28
    • 4.29
    • 4.30
    • 5.0
    • 5.1
    • 5.2
    • 5.3
    • 5.4
    • 5.5
    • 5.6
    • 5.7
    • 6.10
    • 6.11
    • 6.12
    • 6.13
    • 6.14
    • 6.15
    • 6.16
    • 6.2
    • 6.3
    • 6.4
    • 6.5
    • 6.6
    • 6.7
    • 6.8
    • 6.9
    Affected ranges
    • ECOSYSTEM: < 6.17

    Update to 6.17

Original sources

Check your server →