CVE-2022-42252
CVE-2022-42252 · Apache Tomcat request smuggling via malformed content-length
This page contains facts from public vulnerability sources. Check the original advisory before updating.
If Apache Tomcat 8.5.0 to 8.5.82, 9.0.0-M1 to 9.0.67, 10.0.0-M1 to 10.0.26 or 10.1.0-M1 to 10.1.0 was configured to ignore invalid HTTP headers via setting rejectIllegalHeader to false (the default for 8.5.x only), Tomcat did not reject a request containing an invalid Content-Length header making a request smuggling attack possible if Tomcat was located behind a reverse proxy that also failed to reject the request with the invalid header.
CVSS 7.5 · High · EPSS 1.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache tomcat
- Versions
- ≥ 10.1.0-M1, ≤ 10.1.0: Affected (maven)
- ≥ 10.0.0-M1, ≤ 10.0.26: Affected (maven)
- ≥ 9.0.0-M1, ≤ 9.0.67: Affected (maven)
- ≥ 8.5.0, ≤ 8.5.82: Affected (maven)
No fix published
tomcat9 Debian:12
- Affected ranges
- ECOSYSTEM: < 9.0.68-1
Update to 9.0.68-1
tomcat9 Debian:13
- Affected ranges
- ECOSYSTEM: < 9.0.68-1
Update to 9.0.68-1
tomcat9 Debian:14
- Affected ranges
- ECOSYSTEM: < 9.0.68-1
Update to 9.0.68-1
tomcat8 Ubuntu:Pro:18.04:LTS
- Versions
- 8.5.21-1ubuntu1
- 8.5.29-1
- 8.5.30-1
- 8.5.30-1ubuntu1
- 8.5.30-1ubuntu1.2
- 8.5.30-1ubuntu1.3
- 8.5.30-1ubuntu1.4
- 8.5.39-1ubuntu1~18.04.1
- 8.5.39-1ubuntu1~18.04.2
- 8.5.39-1ubuntu1~18.04.3
- Affected ranges
- ECOSYSTEM: < 8.5.39-1ubuntu1~18.04.3+esm1
Update to 8.5.39-1ubuntu1~18.04.3+esm1
tomcat9 Ubuntu:Pro:18.04:LTS
- Versions
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- Affected ranges
- ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2+esm1
Update to 9.0.16-3ubuntu0.18.04.2+esm1
tomcat9 Ubuntu:20.04:LTS
- Versions
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- Affected ranges
- ECOSYSTEM: < 9.0.31-1ubuntu0.5
Update to 9.0.31-1ubuntu0.5
tomcat9 Ubuntu:Pro:22.04:LTS
- Versions
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 9.0.58-1ubuntu0.1+esm1
Update to 9.0.58-1ubuntu0.1+esm1