CVE-2022-43721
CVE-2022-43721 · Apache Superset: Open Redirect Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An authenticated attacker with update datasets permission could change a dataset link to an untrusted site, users could be redirected to this site when clicking on that specific dataset. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.
CVSS 5.4 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache superset
- Versions
- ≥ 2.0.0, < 2.0.1: Affected (semver)
- ≥ 0, ≤ 1.5.2: Affected (semver)
Update to 2.0.1
apache-superset PyPI
- Versions
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- Affected ranges
- ECOSYSTEM: ≤ 1.5.2
No fix published
apache-superset PyPI
- Versions
- 2.0.0
No fix published
apache-superset PyPI
- Versions
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 2.0.0
- Affected ranges
- ECOSYSTEM: < 1.5.3 ∪ ≥ 2.0.0, < 2.0.1
Update to 1.5.3; Update to 2.0.1