p PatchFirst

CVE-2022-47015

CVE-2022-47015

This page contains facts from public vulnerability sources. Check the original advisory before updating.

MariaDB Server before 10.3.34 thru 10.9.3 is vulnerable to Denial of Service. It is possible for function spider_db_mbase::print_warnings to dereference a null pointer.

CVSS 6.5 · Medium · EPSS 1.5% · Fix available

Published
Updated

Stack: system · database

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mariadb Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:10.11.3-1

    Update to 1:10.11.3-1

  • mariadb Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:10.11.3-1

    Update to 1:10.11.3-1

  • mariadb Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:10.11.3-1

    Update to 1:10.11.3-1

  • mariadb-10.3 Ubuntu:20.04:LTS

    Versions
    • 1:10.3.17-1
    • 1:10.3.18-1
    • 1:10.3.19-1
    • 1:10.3.21-2
    • 1:10.3.22-1
    • 1:10.3.22-1ubuntu1
    • 1:10.3.25-0ubuntu0.20.04.1
    • 1:10.3.29-0ubuntu0.20.04.1
    • 1:10.3.30-0ubuntu0.20.04.1
    • 1:10.3.31-0ubuntu0.20.04.1
    • 1:10.3.32-0ubuntu0.20.04.1
    • 1:10.3.34-0ubuntu0.20.04.1
    • 1:10.3.37-0ubuntu0.20.04.1
    • 1:10.3.38-0ubuntu0.20.04.1
    Affected ranges
    • ECOSYSTEM: < 1:10.3.39-0ubuntu0.20.04.2

    Update to 1:10.3.39-0ubuntu0.20.04.2

  • mariadb-10.6 Ubuntu:22.04:LTS

    Versions
    • 1:10.6.7-2ubuntu1
    • 1:10.6.7-2ubuntu1.1
    • 1:10.6.11-0ubuntu0.22.04.1
    • 1:10.6.12-0ubuntu0.22.04.1
    Affected ranges
    • ECOSYSTEM: < 1:10.6.16-0ubuntu0.22.04.1

    Update to 1:10.6.16-0ubuntu0.22.04.1

Original sources

Check your server →