p PatchFirst

CVE-2022-4967

CVE-2022-4967

This page contains facts from public vulnerability sources. Check the original advisory before updating.

strongSwan versions 5.9.2 through 5.9.5 are affected by authorization bypass through improper validation of certificate with host mismatch (CWE-297). When certificates are used to authenticate clients in TLS-based EAP methods, the IKE or EAP identity supplied by a client is not enforced to be contained in the client's certificate. So clients can authenticate with any trusted certificate and claim an arbitrary IKE/EAP identity as their own. This is problematic if the identity is used to make policy decisions. A fix was released in strongSwan version 5.9.6 in August 2022 (e4b4aabc4996fc61c37deab7858d07bc4d220136).

CVSS 7.7 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • strongswan

    Versions
    • ≥ 5.9.2, < 5.9.6: Affected (semver)

    Update to 5.9.6

  • strongswan Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.9.6-1

    Update to 5.9.6-1

  • strongswan Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.9.6-1

    Update to 5.9.6-1

  • strongswan Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.9.6-1

    Update to 5.9.6-1

  • strongswan Ubuntu:22.04:LTS

    Versions
    • 5.9.1-1ubuntu3
    • 5.9.1-1ubuntu3.1
    • 5.9.4-1ubuntu1
    • 5.9.4-1ubuntu2
    • 5.9.4-1ubuntu3
    • 5.9.4-1ubuntu4
    • 5.9.5-2ubuntu1
    • 5.9.5-2ubuntu2
    • 5.9.5-2ubuntu2.1
    • 5.9.5-2ubuntu2.2
    Affected ranges
    • ECOSYSTEM: < 5.9.5-2ubuntu2.3

    Update to 5.9.5-2ubuntu2.3

Original sources

Check your server →