CVE-2022-51010
CVE-2022-51010 · PocketMine-MP before 4.4.2 Server Crash via Item ID
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PocketMine-MP versions before 4.4.2 fail to properly validate item IDs received from clients in itemstack NBT data. Attackers can send crafted item IDs outside the valid range to trigger an uncaught exception that crashes the server.
CVSS 7.1 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
pocketmine-mp
- Versions
- ≥ 0, < 4.4.2: Affected (semver)
- 4.4.2: Not affected (semver)
Update to 4.4.2
pocketmine/pocketmine-mp Packagist
- Versions
- 4.0.0
- 4.0.0-BETA10
- 4.0.0-BETA11
- 4.0.0-BETA12
- 4.0.0-BETA13
- 4.0.0-BETA14
- 4.0.0-BETA15
- 4.0.0-BETA5
- 4.0.0-BETA6
- 4.0.0-BETA7
- 4.0.0-BETA8
- 4.0.0-BETA9
- 4.0.1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 4.0.9
- 4.1.0
- 4.1.0-BETA1
- 4.1.0-BETA2
- 4.2.0
- 4.2.1
- 4.2.10
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.2.9
- 4.3.0
- 4.3.1
- 4.3.2
- 4.3.3
- 4.3.4
- 4.4.0
- 4.4.0-BETA1
- 4.4.1
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0-BETA5, < 4.4.2
Update to 4.4.2