p PatchFirst

CVE-2023-0668

CVE-2023-0668 · Wireshark IEEE-C37.118 parsing buffer overflow

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Due to failure in validating the length provided by an attacker-crafted IEEE-C37.118 packet, Wireshark version 4.0.5 and prior, by default, is susceptible to a heap-based buffer overflow, and possibly code execution in the context of the process running Wireshark.

CVSS 6.5 · Medium · EPSS 2.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • wireshark

    Versions
    • ≥ 4.0.0, ≤ 4.0.5: Affected (semver)
    • 4.0.6: Not affected
    • ≥ 3.6.0, ≤ 3.6.13: Affected (semver)
    • 3.6.14: Not affected

    Update to 3.6.14; Update to 4.0.6

  • wireshark Debian:12

    Versions
    • 4.0.3-1
    • 4.0.5-1~exp1
    Affected ranges
    • ECOSYSTEM: < 4.0.6-1~deb12u1

    Update to 4.0.6-1~deb12u1

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.0.6-1

    Update to 4.0.6-1

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.0.6-1

    Update to 4.0.6-1

  • wireshark Ubuntu:Pro:20.04:LTS

    Versions
    • 3.0.5-1
    • 3.0.7-1
    • 3.2.1-1
    • 3.2.2-1
    • 3.2.3-1
    • 3.2.3-1ubuntu0.1~esm1
    • 3.2.3-1ubuntu0.1~esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wireshark Ubuntu:Pro:22.04:LTS

    Versions
    • 3.4.7-1~exp1
    • 3.4.9-1
    • 3.6.2-1ubuntu1
    • 3.6.2-2
    • 3.6.2-2ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →