CVE-2023-0798
CVE-2023-0798
This page contains facts from public vulnerability sources. Check the original advisory before updating.
LibTIFF 4.4.0 has an out-of-bounds read in tiffcrop in tools/tiffcrop.c:3400, allowing attackers to cause a denial-of-service via a crafted tiff file. For users that compile libtiff from sources, the fix is available with commit afaabc3e.
CVSS 6.8 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libtiff
- Versions
- <=4.4.0: Affected
No fix published
tiff Debian:12
- Affected ranges
- ECOSYSTEM: < 4.5.0-5
Update to 4.5.0-5
tiff Debian:13
- Affected ranges
- ECOSYSTEM: < 4.5.0-5
Update to 4.5.0-5
tiff Debian:14
- Affected ranges
- ECOSYSTEM: < 4.5.0-5
Update to 4.5.0-5
tiff Ubuntu:Pro:14.04:LTS
- Versions
- 4.0.2-4ubuntu3
- 4.0.3-5ubuntu1
- 4.0.3-6
- 4.0.3-6ubuntu1
- 4.0.3-7
- 4.0.3-7ubuntu0.1
- 4.0.3-7ubuntu0.2
- 4.0.3-7ubuntu0.3
- 4.0.3-7ubuntu0.4
- 4.0.3-7ubuntu0.6
- 4.0.3-7ubuntu0.7
- 4.0.3-7ubuntu0.8
- 4.0.3-7ubuntu0.9
- 4.0.3-7ubuntu0.10
- 4.0.3-7ubuntu0.11
- 4.0.3-7ubuntu0.11+esm1
- 4.0.3-7ubuntu0.11+esm2
- 4.0.3-7ubuntu0.11+esm3
- 4.0.3-7ubuntu0.11+esm4
- 4.0.3-7ubuntu0.11+esm5
- 4.0.3-7ubuntu0.11+esm6
- Affected ranges
- ECOSYSTEM: < 4.0.3-7ubuntu0.11+esm7
Update to 4.0.3-7ubuntu0.11+esm7
tiff Ubuntu:Pro:16.04:LTS
- Versions
- 4.0.3-12.3ubuntu2
- 4.0.5-1
- 4.0.6-1
- 4.0.6-1ubuntu0.1
- 4.0.6-1ubuntu0.2
- 4.0.6-1ubuntu0.3
- 4.0.6-1ubuntu0.4
- 4.0.6-1ubuntu0.5
- 4.0.6-1ubuntu0.6
- 4.0.6-1ubuntu0.7
- 4.0.6-1ubuntu0.8
- 4.0.6-1ubuntu0.8+esm1
- 4.0.6-1ubuntu0.8+esm2
- 4.0.6-1ubuntu0.8+esm3
- 4.0.6-1ubuntu0.8+esm4
- 4.0.6-1ubuntu0.8+esm6
- 4.0.6-1ubuntu0.8+esm7
- 4.0.6-1ubuntu0.8+esm8
- 4.0.6-1ubuntu0.8+esm9
- Affected ranges
- ECOSYSTEM: < 4.0.6-1ubuntu0.8+esm10
Update to 4.0.6-1ubuntu0.8+esm10
tiff Ubuntu:18.04:LTS
- Versions
- 4.0.8-5
- 4.0.8-6
- 4.0.9-1
- 4.0.9-2
- 4.0.9-3
- 4.0.9-4
- 4.0.9-4ubuntu1
- 4.0.9-5
- 4.0.9-5ubuntu0.1
- 4.0.9-5ubuntu0.2
- 4.0.9-5ubuntu0.3
- 4.0.9-5ubuntu0.4
- 4.0.9-5ubuntu0.5
- 4.0.9-5ubuntu0.6
- 4.0.9-5ubuntu0.7
- 4.0.9-5ubuntu0.8
- 4.0.9-5ubuntu0.9
- Affected ranges
- ECOSYSTEM: < 4.0.9-5ubuntu0.10
Update to 4.0.9-5ubuntu0.10
tiff Ubuntu:20.04:LTS
- Versions
- 4.0.10+git191003-1
- 4.1.0+git191117-1
- 4.1.0+git191117-2
- 4.1.0+git191117-2build1
- 4.1.0+git191117-2ubuntu0.20.04.1
- 4.1.0+git191117-2ubuntu0.20.04.2
- 4.1.0+git191117-2ubuntu0.20.04.3
- 4.1.0+git191117-2ubuntu0.20.04.4
- 4.1.0+git191117-2ubuntu0.20.04.5
- 4.1.0+git191117-2ubuntu0.20.04.6
- 4.1.0+git191117-2ubuntu0.20.04.7
- Affected ranges
- ECOSYSTEM: < 4.1.0+git191117-2ubuntu0.20.04.8
Update to 4.1.0+git191117-2ubuntu0.20.04.8
tiff Ubuntu:22.04:LTS
- Versions
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.0-3build1
- 4.3.0-4
- 4.3.0-5
- 4.3.0-6
- 4.3.0-6ubuntu0.1
- 4.3.0-6ubuntu0.2
- 4.3.0-6ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 4.3.0-6ubuntu0.4
Update to 4.3.0-6ubuntu0.4
Original sources
- https://gitlab.com/libtiff/libtiff/-/commit/afaabc3e50d4e5d80a94143f7e3c997e7e410f68
- https://gitlab.com/libtiff/libtiff/-/issues/492
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-0798.json
- https://lists.debian.org/debian-lts-announce/2023/02/msg00026.html
- https://www.debian.org/security/2023/dsa-5361
- https://security.netapp.com/advisory/ntap-20230316-0003/
- https://security.gentoo.org/glsa/202305-31
- https://nvd.nist.gov/vuln/detail/CVE-2023-0798