CVE-2023-1523
CVE-2023-1523
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Using the TIOCLINUX ioctl request, a malicious snap could inject contents into the input of the controlling terminal which could allow it to cause arbitrary commands to be executed outside of the snap sandbox after the snap exits. Graphical terminal emulators like xterm, gnome-terminal and others are not affected - this can only be exploited when snaps are run on a virtual console.
CVSS 10.0 · Critical · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
snapd
- Versions
- 2.59.5: Not affected
No fix published
snapd Debian:12
- Versions
- 2.57.6-1
- 2.57.6-1+deb12u1
- 2.59.5-1
- 2.60.2-1
- 2.61.1-1
- 2.61.2-1
- 2.61.2-2
- 2.62-1
- 2.62-2
- 2.62-3
- 2.62-4
- 2.62-5
- 2.63-1
- 2.63-2
- 2.63-3
- 2.63-4
- 2.65.1-1
- 2.65.3-1
- 2.66.1-1
- 2.66.1-2
- 2.67-1
- 2.68.3-2
- 2.68.3-3
- 2.71-1
- 2.71-2
- 2.71-3
- 2.72-1
- 2.73-3
- 2.73-4
- 2.74.1-1
- 2.75.2-1
- 2.75.2-2
- 2.76-1
- 2.76.3-1
- 2.76.3-2
- 2.77.1-1
- 2.77.1-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
snapd Debian:13
- Affected ranges
- ECOSYSTEM: < 2.59.5-1
Update to 2.59.5-1
snapd Debian:14
- Affected ranges
- ECOSYSTEM: < 2.59.5-1
Update to 2.59.5-1
snapd Ubuntu:Pro:16.04:LTS
- Versions
- 1.9
- 1.9.1.1
- 1.9.2
- 2.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.5
- 2.0.8
- 2.0.9
- 2.0.10
- 2.11+0.16.04
- 2.12+0.16.04
- 2.13
- 2.14.2~16.04
- 2.15.2ubuntu1
- 2.16ubuntu3
- 2.17.1ubuntu1
- 2.20.1ubuntu1
- 2.21
- 2.22.2
- 2.22.3
- 2.22.6
- 2.23.1
- 2.24.1
- 2.25
- 2.26.10
- 2.27.5
- 2.28.5
- 2.29.4.2
- 2.32.3.2
- 2.32.9
- 2.33.1ubuntu2
- 2.34.2
- 2.34.2ubuntu0.1
- 2.37.4
- 2.37.4ubuntu0.1
- 2.38
- 2.39.2
- 2.39.2ubuntu0.2
- 2.40
- 2.42.1
- 2.45.1
- 2.45.1ubuntu0.2
- 2.46.1
- 2.47.1
- 2.48
- 2.48.3
- 2.54.3+16.04~esm2
- 2.54.3+16.04.0ubuntu0.1~esm3
- 2.54.3+16.04.0ubuntu0.1~esm4
- 2.54.3+16.04.0ubuntu0.1~esm5
- Affected ranges
- ECOSYSTEM: < 2.54.3+16.04.0ubuntu0.1~esm6
Update to 2.54.3+16.04.0ubuntu0.1~esm6
snapd Ubuntu:18.04:LTS
- Versions
- 2.28.5+17.10
- 2.29.4.1+18.04
- 2.29.4.2+18.04
- 2.31.1+18.04
- 2.32+18.04~pre5
- 2.32+18.04~pre6
- 2.32+18.04
- 2.32.3.2+18.04
- 2.32.5+18.04
- 2.32.8+18.04
- 2.32.9+18.04
- 2.33.1+18.04ubuntu2
- 2.34.2+18.04
- 2.34.2+18.04.1
- 2.37.1+18.04
- 2.37.1.1+18.04
- 2.37.4+18.04
- 2.37.4+18.04.1
- 2.38+18.04
- 2.39.2+18.04
- 2.40+18.04
- 2.42.1+18.04
- 2.45.1+18.04
- 2.45.1+18.04.2
- 2.46.1+18.04
- 2.47.1+18.04
- 2.48+18.04
- 2.48.3+18.04
- 2.49.2+18.04
- 2.51.1+18.04
- 2.54.2+18.04ubuntu1
- 2.54.3+18.04
- 2.54.3+18.04.2ubuntu0.1
- 2.54.3+18.04.2ubuntu0.2
- 2.55.5+18.04
- 2.57.5+18.04
- 2.57.5+18.04ubuntu0.1
- 2.58+18.04
- Affected ranges
- ECOSYSTEM: < 2.58+18.04.1
Update to 2.58+18.04.1
snapd Ubuntu:20.04:LTS
- Versions
- 2.41+19.10.1
- 2.42.1+20.04
- 2.43.3+git1.8109f8
- 2.44~pre1+20.04
- 2.44+20.04
- 2.44.2+20.04
- 2.44.3+20.04
- 2.45.1+20.04
- 2.45.1+20.04.2
- 2.46.1+20.04
- 2.47.1+20.04
- 2.48+20.04
- 2.48.3+20.04
- 2.49.2+20.04
- 2.51.1+20.04ubuntu2
- 2.54.2+20.04ubuntu2
- 2.54.3+20.04
- 2.54.3+20.04.1
- 2.54.3+20.04.1ubuntu0.1
- 2.54.3+20.04.1ubuntu0.2
- 2.54.3+20.04.1ubuntu0.3
- 2.55.5+20.04
- 2.57.5+20.04
- 2.57.5+20.04ubuntu0.1
- 2.58+20.04
- Affected ranges
- ECOSYSTEM: < 2.58+20.04.1
Update to 2.58+20.04.1
snapd Ubuntu:22.04:LTS
- Versions
- 2.53+21.10ubuntu1
- 2.54.2+22.04ubuntu1
- 2.54.2+22.04ubuntu2
- 2.54.2+22.04ubuntu3
- 2.54.3+git19.g868fc21+22.04
- 2.54.3+git26.g360067e+22.04
- 2.55.2+22.04
- 2.55.2+22.04.1
- 2.55.3+22.04
- 2.55.3+22.04ubuntu1
- 2.55.5+22.04
- 2.56.2+22.04ubuntu1
- 2.57.4+22.04
- 2.57.5+22.04
- 2.57.5+22.04ubuntu0.1
- 2.58+22.04
- Affected ranges
- ECOSYSTEM: < 2.58+22.04.1
Update to 2.58+22.04.1