CVE-2023-1916
CVE-2023-1916
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in tiffcrop, a program distributed by the libtiff package. A specially crafted tiff file can lead to an out-of-bounds read in the extractImageSection function in tools/tiffcrop.c, resulting in a denial of service and limited information disclosure. This issue affects libtiff versions 4.x.
CVSS 6.1 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libtiff
- Versions
- libtiff versions 4.x and newer are affected: Affected
No fix published
tiff Debian:12
- Versions
- 4.5.0-6
- 4.5.0-6+deb12u1
- 4.5.0-6+deb12u2
- 4.5.0-6+deb12u3
- 4.5.0-6+deb12u4
- 4.5.1+git230720-1
- 4.5.1+git230720-2
- 4.5.1+git230720-3
- 4.5.1+git230720-4
- 4.5.1+git230720-5
- 4.5.1-1
- 4.5.1~rc3-1
- 4.6.0-1
- 4.6.0-2
- 4.7.0-1
- 4.7.0-2
- 4.7.0-3
- 4.7.0-4
- 4.7.0-5
- 4.7.1-1
- 4.7.1-2
- 4.7.1-3
- 4.7.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tiff Debian:13
- Affected ranges
- ECOSYSTEM: < 4.7.0-1
Update to 4.7.0-1
tiff Debian:14
- Affected ranges
- ECOSYSTEM: < 4.7.0-1
Update to 4.7.0-1
tiff Ubuntu:Pro:14.04:LTS
- Versions
- 4.0.2-4ubuntu3
- 4.0.3-5ubuntu1
- 4.0.3-6
- 4.0.3-6ubuntu1
- 4.0.3-7
- 4.0.3-7ubuntu0.1
- 4.0.3-7ubuntu0.2
- 4.0.3-7ubuntu0.3
- 4.0.3-7ubuntu0.4
- 4.0.3-7ubuntu0.6
- 4.0.3-7ubuntu0.7
- 4.0.3-7ubuntu0.8
- 4.0.3-7ubuntu0.9
- 4.0.3-7ubuntu0.10
- 4.0.3-7ubuntu0.11
- 4.0.3-7ubuntu0.11+esm1
- 4.0.3-7ubuntu0.11+esm2
- 4.0.3-7ubuntu0.11+esm3
- 4.0.3-7ubuntu0.11+esm4
- 4.0.3-7ubuntu0.11+esm5
- 4.0.3-7ubuntu0.11+esm6
- 4.0.3-7ubuntu0.11+esm7
- 4.0.3-7ubuntu0.11+esm8
- 4.0.3-7ubuntu0.11+esm9
- Affected ranges
- ECOSYSTEM: < 4.0.3-7ubuntu0.11+esm10
Update to 4.0.3-7ubuntu0.11+esm10
tiff Ubuntu:Pro:16.04:LTS
- Versions
- 4.0.3-12.3ubuntu2
- 4.0.5-1
- 4.0.6-1
- 4.0.6-1ubuntu0.1
- 4.0.6-1ubuntu0.2
- 4.0.6-1ubuntu0.3
- 4.0.6-1ubuntu0.4
- 4.0.6-1ubuntu0.5
- 4.0.6-1ubuntu0.6
- 4.0.6-1ubuntu0.7
- 4.0.6-1ubuntu0.8
- 4.0.6-1ubuntu0.8+esm1
- 4.0.6-1ubuntu0.8+esm2
- 4.0.6-1ubuntu0.8+esm3
- 4.0.6-1ubuntu0.8+esm4
- 4.0.6-1ubuntu0.8+esm6
- 4.0.6-1ubuntu0.8+esm7
- 4.0.6-1ubuntu0.8+esm8
- 4.0.6-1ubuntu0.8+esm9
- 4.0.6-1ubuntu0.8+esm10
- 4.0.6-1ubuntu0.8+esm11
- 4.0.6-1ubuntu0.8+esm12
- Affected ranges
- ECOSYSTEM: < 4.0.6-1ubuntu0.8+esm13
Update to 4.0.6-1ubuntu0.8+esm13
tiff Ubuntu:Pro:18.04:LTS
- Versions
- 4.0.8-5
- 4.0.8-6
- 4.0.9-1
- 4.0.9-2
- 4.0.9-3
- 4.0.9-4
- 4.0.9-4ubuntu1
- 4.0.9-5
- 4.0.9-5ubuntu0.1
- 4.0.9-5ubuntu0.2
- 4.0.9-5ubuntu0.3
- 4.0.9-5ubuntu0.4
- 4.0.9-5ubuntu0.5
- 4.0.9-5ubuntu0.6
- 4.0.9-5ubuntu0.7
- 4.0.9-5ubuntu0.8
- 4.0.9-5ubuntu0.9
- 4.0.9-5ubuntu0.10
- 4.0.9-5ubuntu0.10+esm1
- 4.0.9-5ubuntu0.10+esm2
- Affected ranges
- ECOSYSTEM: < 4.0.9-5ubuntu0.10+esm3
Update to 4.0.9-5ubuntu0.10+esm3
tiff Ubuntu:20.04:LTS
- Versions
- 4.0.10+git191003-1
- 4.1.0+git191117-1
- 4.1.0+git191117-2
- 4.1.0+git191117-2build1
- 4.1.0+git191117-2ubuntu0.20.04.1
- 4.1.0+git191117-2ubuntu0.20.04.2
- 4.1.0+git191117-2ubuntu0.20.04.3
- 4.1.0+git191117-2ubuntu0.20.04.4
- 4.1.0+git191117-2ubuntu0.20.04.5
- 4.1.0+git191117-2ubuntu0.20.04.6
- 4.1.0+git191117-2ubuntu0.20.04.7
- 4.1.0+git191117-2ubuntu0.20.04.8
- 4.1.0+git191117-2ubuntu0.20.04.9
- Affected ranges
- ECOSYSTEM: < 4.1.0+git191117-2ubuntu0.20.04.10
Update to 4.1.0+git191117-2ubuntu0.20.04.10
tiff Ubuntu:22.04:LTS
- Versions
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.0-3build1
- 4.3.0-4
- 4.3.0-5
- 4.3.0-6
- 4.3.0-6ubuntu0.1
- 4.3.0-6ubuntu0.2
- 4.3.0-6ubuntu0.3
- 4.3.0-6ubuntu0.4
- 4.3.0-6ubuntu0.5
- Affected ranges
- ECOSYSTEM: < 4.3.0-6ubuntu0.6
Update to 4.3.0-6ubuntu0.6
tiff Ubuntu:24.04:LTS
- Versions
- 4.5.1+git230720-1ubuntu1
- 4.5.1+git230720-3ubuntu1
- Affected ranges
- ECOSYSTEM: < 4.5.1+git230720-4ubuntu1
Update to 4.5.1+git230720-4ubuntu1