CVE-2023-22946
CVE-2023-22946 · Apache Spark proxy-user privilege escalation from malicious configuration class
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0 or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.
CVSS 6.4 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache spark
- Versions
- ≥ 0, < 3.4.0: Affected (semver)
Update to 3.4.0
org.apache.spark:spark-core_2.12 Maven
- Versions
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 3.0.0
- 3.0.0-preview
- 3.0.0-preview2
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.3.0
- 3.3.1
- 3.3.2
- Affected ranges
- ECOSYSTEM: < 3.3.3
Update to 3.3.3
org.apache.spark:spark-core_2.13 Maven
- Versions
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.3.0
- 3.3.1
- 3.3.2
- Affected ranges
- ECOSYSTEM: < 3.3.3
Update to 3.3.3
pyspark PyPI
- Versions
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.1
- 3.1.2
- 3.1.3
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.3.0
- 3.3.1
- Affected ranges
- ECOSYSTEM: < 3.3.2
Update to 3.3.2
pyspark PyPI
- Versions
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.1.1
- 3.1.2
- 3.1.3
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- Affected ranges
- ECOSYSTEM: < 3.4.0
Update to 3.4.0