CVE-2023-23922
CVE-2023-23922 · Moodle: reflected xss risk in blog search
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in blog search. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website. This flaw allows a remote attacker to perform cross-site scripting (XSS) attacks.
CVSS 6.1 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Affected products and versions
moodle/moodle Packagist
- Versions
- v4.0.0
- v4.0.0-beta
- v4.0.0-rc1
- v4.0.0-rc2
- v4.0.0-rc3
- v4.0.0-rc4
- v4.0.1
- v4.0.2
- v4.0.3
- v4.0.4
- v4.0.5
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0-beta, < 4.0.6
Update to 4.0.6
moodle/moodle Packagist
- Versions
- v4.1.0
- v4.1.0-beta
- v4.1.0-rc1
- v4.1.0-rc2
- v4.1.0-rc3
- Affected ranges
- ECOSYSTEM: ≥ 4.1.0-beta, < 4.1.1
Update to 4.1.1
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published