p PatchFirst

CVE-2023-24258

CVE-2023-24258

This page contains facts from public vulnerability sources. Check the original advisory before updating.

SPIP v4.1.5 and earlier was discovered to contain a SQL injection vulnerability via the _oups parameter. This vulnerability allows attackers to execute arbitrary code via a crafted POST request.

CVSS 9.8 · Critical · EPSS 1.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • spip Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.1.7+dfsg-1

    Update to 4.1.7+dfsg-1

  • spip Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.1.7+dfsg-1

    Update to 4.1.7+dfsg-1

  • spip Ubuntu:Pro:16.04:LTS

    Versions
    • 3.0.20-1
    • 3.0.21-1
    • 3.0.21-1ubuntu1
    • 3.0.21-1ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • spip Ubuntu:Pro:18.04:LTS

    Versions
    • 3.1.4-3
    • 3.1.4-4~deb9u3build0.18.04.1
    • 3.1.4-4~deb9u5build0.18.04.1
    Affected ranges
    • ECOSYSTEM: < 3.1.4-4~deb9u5ubuntu0.1~esm2

    Update to 3.1.4-4~deb9u5ubuntu0.1~esm2

  • spip Ubuntu:Pro:20.04:LTS

    Versions
    • 3.2.4-1
    • 3.2.5-1
    • 3.2.7-1
    • 3.2.7-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 3.2.7-1ubuntu0.1+esm2

    Update to 3.2.7-1ubuntu0.1+esm2

  • spip Ubuntu:22.04:LTS

    Versions
    • 3.2.11-3
    • 3.2.12-1
    • 4.0.2-1
    • 4.0.4-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →