CVE-2023-2454
CVE-2023-2454
This page contains facts from public vulnerability sources. Check the original advisory before updating.
schema_element defeats protective search_path changes; It was found that certain database calls in PostgreSQL could permit an authed attacker with elevated database-level privileges to execute arbitrary code.
CVSS 7.2 · High · EPSS 1.2% · Fix available
- Published
- Updated
Affected products and versions
postgresql
- Versions
- PostgreSQL 15.3, PostgreSQL 14.8, PostgreSQL 13.11, PostgreSQL 12.15, PostgreSQL 11.20: Affected
No fix published
postgresql-15 Debian:12
- Affected ranges
- ECOSYSTEM: < 15.3-0+deb12u1
Update to 15.3-0+deb12u1
postgresql-9.3 Ubuntu:Pro:14.04:LTS
- Versions
- 9.3.1-1
- 9.3.2-1
- 9.3.2-1ubuntu1
- 9.3.2-1ubuntu2
- 9.3.3-1
- 9.3.3-1bzr1
- 9.3.3-1bzr2
- 9.3.4-1
- 9.3.5-0ubuntu0.14.04.1
- 9.3.6-0ubuntu0.14.04
- 9.3.7-0ubuntu0.14.04
- 9.3.8-0ubuntu0.4.04
- 9.3.9-0ubuntu0.14.04
- 9.3.10-0ubuntu0.14.04
- 9.3.11-0ubuntu0.14.04
- 9.3.12-0ubuntu0.14.04
- 9.3.13-0ubuntu0.14.04
- 9.3.14-0ubuntu0.14.04
- 9.3.15-0ubuntu0.14.04
- 9.3.16-0ubuntu0.14.04
- 9.3.17-0ubuntu0.14.04
- 9.3.18-0ubuntu0.14.04.1
- 9.3.19-0ubuntu0.14.04
- 9.3.20-0ubuntu0.14.04
- 9.3.21-0ubuntu0.14.04
- 9.3.22-0ubuntu0.14.04
- 9.3.23-0ubuntu0.14.04
- 9.3.24-0ubuntu0.14.04
- 9.3.24-0ubuntu0.14.04+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
postgresql-9.5 Ubuntu:Pro:16.04:LTS
- Versions
- 9.5.0-1
- 9.5.0-2
- 9.5.0-3
- 9.5.1-1
- 9.5.2-1
- 9.5.3-0ubuntu0.16.04
- 9.5.4-0ubuntu0.16.04
- 9.5.5-0ubuntu0.16.04
- 9.5.6-0ubuntu0.16.04
- 9.5.7-0ubuntu0.16.04
- 9.5.8-0ubuntu0.16.04.1
- 9.5.9-0ubuntu0.16.04
- 9.5.10-0ubuntu0.16.04
- 9.5.11-0ubuntu0.16.04
- 9.5.12-0ubuntu0.16.04
- 9.5.13-0ubuntu0.16.04
- 9.5.14-0ubuntu0.16.04
- 9.5.16-0ubuntu0.16.04.1
- 9.5.17-0ubuntu0.16.04.1
- 9.5.18-0ubuntu0.16.04.1
- 9.5.19-0ubuntu0.16.04.1
- 9.5.21-0ubuntu0.16.04.1
- 9.5.23-0ubuntu0.16.04.1
- 9.5.24-0ubuntu0.16.04.1
- 9.5.25-0ubuntu0.16.04.1
- 9.5.25-0ubuntu0.16.04.1+esm1
- 9.5.25-0ubuntu0.16.04.1+esm2
- 9.5.25-0ubuntu0.16.04.1+esm3
- Affected ranges
- ECOSYSTEM: < 9.5.25-0ubuntu0.16.04.1+esm4
Update to 9.5.25-0ubuntu0.16.04.1+esm4
postgresql-10 Ubuntu:18.04:LTS
- Versions
- 10.1-1
- 10.1-2
- 10.2-1
- 10.3-1
- 10.4-0ubuntu0.18.04
- 10.5-0ubuntu0.18.04
- 10.6-0ubuntu0.18.04.1
- 10.7-0ubuntu0.18.04.1
- 10.8-0ubuntu0.18.04.1
- 10.9-0ubuntu0.18.04.1
- 10.10-0ubuntu0.18.04.1
- 10.12-0ubuntu0.18.04.1
- 10.14-0ubuntu0.18.04.1
- 10.15-0ubuntu0.18.04.1
- 10.16-0ubuntu0.18.04.1
- 10.17-0ubuntu0.18.04.1
- 10.18-0ubuntu0.18.04.1
- 10.19-0ubuntu0.18.04.1
- 10.20-0ubuntu0.18.04.1
- 10.21-0ubuntu0.18.04.1
- 10.22-0ubuntu0.18.04.1
- 10.23-0ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 10.23-0ubuntu0.18.04.2
Update to 10.23-0ubuntu0.18.04.2
postgresql-12 Ubuntu:20.04:LTS
- Versions
- 12.0-1
- 12.1-1
- 12.1-2build1
- 12.2-1
- 12.2-1ubuntu2
- 12.2-4
- 12.4-0ubuntu0.20.04.1
- 12.5-0ubuntu0.20.04.1
- 12.6-0ubuntu0.20.04.1
- 12.7-0ubuntu0.20.04.1
- 12.8-0ubuntu0.20.04.1
- 12.9-0ubuntu0.20.04.1
- 12.10-0ubuntu0.20.04.1
- 12.11-0ubuntu0.20.04.1
- 12.12-0ubuntu0.20.04.1
- 12.13-0ubuntu0.20.04.1
- 12.14-0ubuntu0.20.04.1
- Affected ranges
- ECOSYSTEM: < 12.15-0ubuntu0.20.04.1
Update to 12.15-0ubuntu0.20.04.1
postgresql-14 Ubuntu:22.04:LTS
- Versions
- 14.1-1ubuntu1
- 14.2-1
- 14.2-1ubuntu1
- 14.3-0ubuntu0.22.04.1
- 14.4-0ubuntu0.22.04.1
- 14.5-0ubuntu0.22.04.1
- 14.6-0ubuntu0.22.04.1
- 14.7-0ubuntu0.22.04.1
- Affected ranges
- ECOSYSTEM: < 14.8-0ubuntu0.22.04.1
Update to 14.8-0ubuntu0.22.04.1