CVE-2023-25571
CVE-2023-25571 · Backstage has XSS Vulnerability in Software Catalog
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Backstage is an open platform for building developer portals. `@backstage/catalog-model` prior to version 1.2.0, `@backstage/core-components` prior to 0.12.4, and `@backstage/plugin-catalog-backend` prior to 1.7.2 are affected by a cross-site scripting vulnerability. This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack. This vulnerability has been patched in both the frontend and backend implementations. The default `Link` component from `@backstage/core-components` version 1.2.0 and greater will now reject `javascript:` URLs, and there is a global override of `window.open` to do the same. In addition, the catalog model v0.12.4 and greater as well as the catalog backend v1.7.2 and greater now has additional validation built in that prevents `javascript:` URLs in known annotations. As a workaround, the general practice of limiting access to modifying catalog content and requiring code reviews greatly help mitigate this vulnerability.
CVSS 6.8 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
backstage
- Versions
- < 1.2.0: Affected
- < 0.12.4: Affected
- < 1.7.2: Affected
No fix published
@backstage/core-components npm
- Affected ranges
- SEMVER: < 0.12.4
Update to 0.12.4
@backstage/catalog-model npm
- Affected ranges
- SEMVER: < 1.2.0
Update to 1.2.0
@backstage/plugin-catalog-backend npm
- Affected ranges
- SEMVER: < 1.7.2
Update to 1.7.2