CVE-2023-25577
CVE-2023-25577 · Werkzeug may allow high resource usage when parsing multipart form data with many fields
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Werkzeug is a comprehensive WSGI web application library. Prior to version 2.2.3, Werkzeug's multipart form data parser will parse an unlimited number of parts, including file parts. Parts can be a small amount of bytes, but each requires CPU time to parse and may use more memory as Python data. If a request can be made to an endpoint that accesses `request.data`, `request.form`, `request.files`, or `request.get_data(parse_form_data=False)`, it can cause unexpectedly high resource usage. This allows an attacker to cause a denial of service by sending crafted multipart data to an endpoint that will parse it. The amount of CPU time required can block worker processes from handling legitimate requests. The amount of RAM required can trigger an out of memory kill of the process. Unlimited file parts can use up memory and file handles. If many concurrent requests are sent continuously, this can exhaust or kill all available workers. Version 2.2.3 contains a patch for this issue.
CVSS 7.5 · High · EPSS 1.4% · Fix available
- Published
- Updated
Affected products and versions
werkzeug
- Versions
- < 2.2.3: Affected
No fix published
python-werkzeug Debian:12
- Affected ranges
- ECOSYSTEM: < 2.2.2-3
Update to 2.2.2-3
python-werkzeug Debian:13
- Affected ranges
- ECOSYSTEM: < 2.2.2-3
Update to 2.2.2-3
python-werkzeug Debian:14
- Affected ranges
- ECOSYSTEM: < 2.2.2-3
Update to 2.2.2-3
werkzeug PyPI
- Versions
- 0.1
- 0.10
- 0.10.1
- 0.10.2
- 0.10.3
- 0.10.4
- 0.11
- 0.11.1
- 0.11.10
- 0.11.11
- 0.11.12
- 0.11.13
- 0.11.14
- 0.11.15
- 0.11.2
- 0.11.3
- 0.11.4
- 0.11.5
- 0.11.6
- 0.11.7
- 0.11.8
- 0.11.9
- 0.12
- 0.12.1
- 0.12.2
- 0.13
- 0.14
- 0.14.1
- 0.15.0
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.4
- 0.15.5
- 0.15.6
- 0.16.0
- 0.16.1
- 0.2
- 0.3
- 0.3.1
- 0.4
- 0.4.1
- 0.5
- 0.5.1
- 0.6
- 0.6.1
- 0.6.2
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 0.9
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 1.0.0
- 1.0.0rc1
- 1.0.1
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.0a1
- 2.2.1
- 2.2.2
- Affected ranges
- ECOSYSTEM: < 2.2.3
Update to 2.2.3
werkzeug PyPI
- Versions
- 0.1
- 0.10
- 0.10.1
- 0.10.2
- 0.10.3
- 0.10.4
- 0.11
- 0.11.1
- 0.11.10
- 0.11.11
- 0.11.12
- 0.11.13
- 0.11.14
- 0.11.15
- 0.11.2
- 0.11.3
- 0.11.4
- 0.11.5
- 0.11.6
- 0.11.7
- 0.11.8
- 0.11.9
- 0.12
- 0.12.1
- 0.12.2
- 0.13
- 0.14
- 0.14.1
- 0.15.0
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.4
- 0.15.5
- 0.15.6
- 0.16.0
- 0.16.1
- 0.2
- 0.3
- 0.3.1
- 0.4
- 0.4.1
- 0.5
- 0.5.1
- 0.6
- 0.6.1
- 0.6.2
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 0.9
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 1.0.0
- 1.0.0rc1
- 1.0.1
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.0a1
- 2.2.1
- 2.2.2
- Affected ranges
- GIT: < 517cac5a804e8c4dc4ed038bb20dacd038e7a9f1
- ECOSYSTEM: < 2.2.3
Update to 2.2.3
python-werkzeug Ubuntu:Pro:16.04:LTS
- Versions
- 0.10.4+dfsg1-1ubuntu1
- 0.10.4+dfsg1-1ubuntu1.1
- 0.10.4+dfsg1-1ubuntu1.2
- Affected ranges
- ECOSYSTEM: < 0.10.4+dfsg1-1ubuntu1.2+esm1
Update to 0.10.4+dfsg1-1ubuntu1.2+esm1
python-werkzeug Ubuntu:18.04:LTS
- Versions
- 0.12.2+dfsg1-2
- 0.13+dfsg1-1
- 0.14.1+dfsg1-1
- 0.14.1+dfsg1-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 0.14.1+dfsg1-1ubuntu0.2
Update to 0.14.1+dfsg1-1ubuntu0.2
python-werkzeug Ubuntu:20.04:LTS
- Versions
- 0.14.1+dfsg1-4
- 0.15.6+dfsg1-1
- 0.16.0+dfsg1-1
- 0.16.1+dfsg1-1ubuntu1
- 0.16.1+dfsg1-2
- Affected ranges
- ECOSYSTEM: < 0.16.1+dfsg1-2ubuntu0.1
Update to 0.16.1+dfsg1-2ubuntu0.1
python-werkzeug Ubuntu:22.04:LTS
- Versions
- 1.0.1+dfsg1-2
- 2.0.2+dfsg1-1
- Affected ranges
- ECOSYSTEM: < 2.0.2+dfsg1-1ubuntu0.22.04.1
Update to 2.0.2+dfsg1-1ubuntu0.22.04.1
Original sources
- https://github.com/pallets/werkzeug/security/advisories/GHSA-xg9f-g7g7-2323
- https://github.com/pallets/werkzeug/commit/517cac5a804e8c4dc4ed038bb20dacd038e7a9f1
- https://github.com/pallets/werkzeug/releases/tag/2.2.3
- https://www.debian.org/security/2023/dsa-5470
- https://security.netapp.com/advisory/ntap-20230818-0003/
- https://nvd.nist.gov/vuln/detail/CVE-2023-25577