p PatchFirst

CVE-2023-25691

CVE-2023-25691 · Apache Airflow Google Provider: Google Cloud Sql Provider Remote Command Execution

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Input Validation vulnerability in the Apache Airflow Google Provider. This issue affects Apache Airflow Google Provider versions before 8.10.0.

CVSS 9.8 · Critical · EPSS 1.6% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • apache airflow google provider

    Versions
    • ≥ 0, < 8.10.0: Affected (semver)

    Update to 8.10.0

  • apache-airflow-providers-google PyPI

    Versions
    • 1.0.0
    • 1.0.0b1
    • 1.0.0b2
    • 1.0.0rc1
    • 2.0.0
    • 2.0.0rc1
    • 2.1.0
    • 2.1.0rc1
    • 2.2.0
    • 2.2.0rc1
    • 3.0.0
    • 3.0.0rc1
    • 4.0.0
    • 4.0.0rc1
    • 4.0.0rc2
    • 4.1.0rc1
    • 5.0.0
    • 5.0.0rc2
    • 5.1.0
    • 5.1.0rc1
    • 6.0.0
    • 6.0.0rc1
    • 6.1.0
    • 6.1.0rc1
    • 6.2.0
    • 6.2.0rc1
    • 6.3.0
    • 6.3.0rc1
    • 6.4.0
    • 6.4.0rc1
    • 6.4.0rc2
    • 6.4.0rc3
    • 6.5.0
    • 6.5.0rc1
    • 6.6.0
    • 6.6.0rc1
    • 6.7.0
    • 6.7.0rc1
    • 6.8.0
    • 6.8.0rc1
    • 7.0.0
    • 7.0.0rc1
    • 8.0.0
    • 8.0.0rc1
    • 8.0.0rc2
    • 8.1.0
    • 8.1.0rc1
    • 8.10.0rc1
    • 8.2.0
    • 8.2.0rc1
    • 8.3.0
    • 8.3.0rc1
    • 8.3.0rc2
    • 8.3.0rc3
    • 8.4.0
    • 8.4.0rc1
    • 8.4.0rc2
    • 8.5.0
    • 8.5.0rc1
    • 8.6.0
    • 8.6.0rc2
    • 8.6.0rc3
    • 8.7.0
    • 8.7.0rc1
    • 8.7.0rc2
    • 8.8.0
    • 8.8.0rc1
    • 8.9.0
    • 8.9.0rc1
    Affected ranges
    • ECOSYSTEM: < 8.10.0

    Update to 8.10.0

Original sources

Check your server →