CVE-2023-25956
CVE-2023-25956 · Apache Airflow AWS Provider: Arbitrary file read via AWS provider
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Generation of Error Message Containing Sensitive Information vulnerability in the Apache Airflow AWS Provider. This issue affects Apache Airflow AWS Provider versions before 7.2.1.
CVSS 7.5 · High · EPSS 1.5% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow aws provider
- Versions
- ≥ 0, < 7.2.1: Affected (semver)
Update to 7.2.1
apache-airflow-providers-amazon PyPI
- Versions
- 1.0.0
- 1.0.0b1
- 1.0.0b2
- 1.0.0rc1
- 1.1.0
- 1.1.0rc1
- 1.2.0
- 1.2.0rc1
- 1.3.0
- 1.3.0rc1
- 1.4.0
- 1.4.0rc1
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.1.0
- 2.1.0rc1
- 2.1.0rc2
- 2.2.0
- 2.2.0rc1
- 2.3.0
- 2.3.0rc1
- 2.3.0rc2
- 2.4.0
- 2.4.0rc1
- 2.4.0rc2
- 2.5.0
- 2.5.0rc1
- 2.6.0
- 2.6.0rc1
- 3.0.0
- 3.0.0rc1
- 3.0.0rc2
- 3.1.0rc1
- 3.1.1
- 3.1.1rc1
- 3.2.0
- 3.2.0rc1
- 3.3.0
- 3.3.0rc1
- 3.4.0
- 3.4.0rc1
- 4.0.0
- 4.0.0rc1
- 4.0.0rc2
- 4.1.0
- 4.1.0rc1
- 5.0.0
- 5.0.0rc1
- 5.0.0rc2
- 5.0.0rc3
- 5.1.0
- 5.1.0rc1
- 6.0.0
- 6.0.0rc1
- 6.1.0
- 6.1.0rc1
- 6.2.0
- 6.2.0rc2
- 6.2.0rc3
- 7.0.0
- 7.0.0rc1
- 7.0.0rc2
- 7.1.0
- 7.1.0rc1
- 7.2.0
- 7.2.0rc1
- 7.2.1rc1
- Affected ranges
- ECOSYSTEM: < 7.2.1
Update to 7.2.1