p PatchFirst

CVE-2023-26114

CVE-2023-26114

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package code-server before 4.10.1 are vulnerable to Missing Origin Validation in WebSockets handshakes. Exploiting this vulnerability can allow an adversary in specific scenarios to access data from and connect to the code-server instance.

CVSS 8.2 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • code-server

    Versions
    • ≥ 0, < 4.10.1: Affected (semver)

    Update to 4.10.1

  • code-server npm

    Affected ranges
    • SEMVER: < 4.10.1

    Update to 4.10.1

Original sources

Check your server →