p PatchFirst

CVE-2023-2700

CVE-2023-2700

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was found in libvirt. This security flaw ouccers due to repeatedly querying an SR-IOV PCI device's capabilities that exposes a memory leak caused by a failure to free the virPCIVirtualFunction array within the parent struct's g_autoptr cleanup.

CVSS 5.5 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • libvirt

    Versions
    • libvirt-4.5.0: Affected

    No fix published

  • libvirt Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.0.0-4

    Update to 9.0.0-4

  • libvirt Debian:13

    Affected ranges
    • ECOSYSTEM: < 9.0.0-4

    Update to 9.0.0-4

  • libvirt Debian:14

    Affected ranges
    • ECOSYSTEM: < 9.0.0-4

    Update to 9.0.0-4

  • libvirt Ubuntu:22.04:LTS

    Versions
    • 7.6.0-0ubuntu1
    • 7.6.0-0ubuntu3
    • 8.0.0-1ubuntu3
    • 8.0.0-1ubuntu4
    • 8.0.0-1ubuntu5
    • 8.0.0-1ubuntu6
    • 8.0.0-1ubuntu7
    • 8.0.0-1ubuntu7.1
    • 8.0.0-1ubuntu7.2
    • 8.0.0-1ubuntu7.3
    • 8.0.0-1ubuntu7.4
    Affected ranges
    • ECOSYSTEM: < 8.0.0-1ubuntu7.5

    Update to 8.0.0-1ubuntu7.5

Original sources

Check your server →