p PatchFirst

CVE-2023-27494

CVE-2023-27494 · Streamlit Cross-site Scripting vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Streamlit, software for turning data scripts into web applications, had a cross-site scripting (XSS) vulnerability in versions 0.63.0 through 0.80.0. Users of hosted Streamlit app(s) were vulnerable to a reflected XSS vulnerability. An attacker could craft a malicious URL with Javascript payloads to a Streamlit app. The attacker could then trick the user into visiting the malicious URL and, if successful, the server would render the malicious javascript payload as-is, leading to XSS. Version 0.81.0 contains a patch for this vulnerability.

CVSS 5.9 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • streamlit

    Versions
    • >= 0.63.0, < 0.81.0: Affected

    No fix published

  • streamlit PyPI

    Versions
    • 0.63.0
    • 0.63.1
    • 0.64.0
    • 0.65.0
    • 0.65.1
    • 0.65.2
    • 0.66.0
    • 0.67.0
    • 0.67.1
    • 0.68.0
    • 0.68.1
    • 0.69.0
    • 0.69.1
    • 0.69.2
    • 0.70.0
    • 0.71.0
    • 0.72.0
    • 0.73.0
    • 0.73.1
    • 0.74.0
    • 0.74.1
    • 0.75.0
    • 0.76.0
    • 0.77.0
    • 0.78.0
    • 0.79.0
    • 0.80.0
    Affected ranges
    • ECOSYSTEM: ≥ 0.63.0, < 0.81.0

    Update to 0.81.0

  • streamlit PyPI

    Versions
    • 0.63.0
    • 0.63.1
    • 0.64.0
    • 0.65.0
    • 0.65.1
    • 0.65.2
    • 0.66.0
    • 0.67.0
    • 0.67.1
    • 0.68.0
    • 0.68.1
    • 0.69.0
    • 0.69.1
    • 0.69.2
    • 0.70.0
    • 0.71.0
    • 0.72.0
    • 0.73.0
    • 0.73.1
    • 0.74.0
    • 0.74.1
    • 0.75.0
    • 0.76.0
    • 0.77.0
    • 0.78.0
    • 0.79.0
    • 0.80.0
    Affected ranges
    • GIT: < afcf880c60e5d7538936cc2d9721b9e1bc02b075
    • ECOSYSTEM: ≥ 0.63.0, < 0.81.0

    Update to 0.81.0

Original sources

Check your server →