CVE-2023-27577
CVE-2023-27577 · Path Traversal Vulnerability in `LESS` Parser allows reading of sensitive server files in flarum
This page contains facts from public vulnerability sources. Check the original advisory before updating.
flarum is a forum software package for building communities. In versions prior to 1.7.0 an admin account which has already been compromised by an attacker may use a vulnerability in the `LESS` parser which can be exploited to read sensitive files on the server through the use of path traversal techniques. An attacker can achieve this by providing an absolute path to a sensitive file in the custom `LESS` setting, which the `LESS` parser will then read. For example, an attacker could use the following code to read the contents of the `/etc/passwd` file on a linux machine. The scope of what files are vulnerable will depend on the permissions given to the running flarum process. The vulnerability has been addressed in version `1.7`. Users should upgrade to this version to mitigate the vulnerability. Users unable to upgrade may mitigate the vulnerability by ensuring that their admin accounts are secured with strong passwords and follow other best practices for account security. Additionally, users can limit the exposure of sensitive files on the server by implementing appropriate file permissions and access controls at the operating system level.
CVSS 6.6 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
framework
- Versions
- < 1.7.0: Affected
No fix published
flarum/core Packagist
- Versions
- v0.1.0-beta
- v0.1.0-beta.10
- v0.1.0-beta.11
- v0.1.0-beta.11.1
- v0.1.0-beta.12
- v0.1.0-beta.13
- v0.1.0-beta.14
- v0.1.0-beta.14.1
- v0.1.0-beta.15
- v0.1.0-beta.16
- v0.1.0-beta.2
- v0.1.0-beta.3
- v0.1.0-beta.4
- v0.1.0-beta.5
- v0.1.0-beta.6
- v0.1.0-beta.7
- v0.1.0-beta.7.1
- v0.1.0-beta.7.2
- v0.1.0-beta.8
- v0.1.0-beta.8.1
- v0.1.0-beta.8.2
- v0.1.0-beta.9
- v1.0.0
- v1.0.1
- v1.0.2
- v1.0.3
- v1.0.4
- v1.1.0
- v1.1.1
- v1.2.0
- v1.2.1
- v1.3.0
- v1.3.1
- v1.4.0
- v1.4.1
- v1.5.0
- v1.6.0
- v1.6.1
- v1.6.2
- v1.6.3
- Affected ranges
- ECOSYSTEM: < 1.7.0
Update to 1.7.0