CVE-2023-28709
CVE-2023-28709 · Apache Tomcat: Fix for CVE-2023-24998 is incomplete
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The fix for CVE-2023-24998 was incomplete for Apache Tomcat 11.0.0-M2 to 11.0.0-M4, 10.1.5 to 10.1.7, 9.0.71 to 9.0.73 and 8.5.85 to 8.5.87. If non-default HTTP connector settings were used such that the maxParameterCount could be reached using query string parameters and a request was submitted that supplied exactly maxParameterCount parameters in the query string, the limit for uploaded request parts could be bypassed with the potential for a denial of service to occur.
CVSS 7.5 · High · EPSS 48.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache tomcat
- Versions
- ≥ 11.0.0-M2, ≤ 11.0.0-M4: Affected (semver)
- ≥ 10.1.5, ≤ 10.1.7: Affected (semver)
- ≥ 9.0.71, ≤ 9.0.73: Affected (semver)
- ≥ 8.5.85, ≤ 8.5.87: Affected (semver)
No fix published
tomcat10 Debian:12
- Versions
- 10.1.6-1
- Affected ranges
- ECOSYSTEM: < 10.1.6-1+deb12u1
Update to 10.1.6-1+deb12u1
tomcat10 Debian:13
- Affected ranges
- ECOSYSTEM: < 10.1.10-1
Update to 10.1.10-1
tomcat10 Debian:14
- Affected ranges
- ECOSYSTEM: < 10.1.10-1
Update to 10.1.10-1
Original sources
- https://lists.apache.org/thread/7wvxonzwb7k9hx9jt3q33cmy7j97jo3j
- http://www.openwall.com/lists/oss-security/2023/05/22/1
- https://security.gentoo.org/glsa/202305-37
- https://security.netapp.com/advisory/ntap-20230616-0004/
- https://www.debian.org/security/2023/dsa-5521
- https://nvd.nist.gov/vuln/detail/CVE-2023-28709