p PatchFirst

CVE-2023-2906

CVE-2023-2906 · Wireshark CP2179 divide by zero

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Due to a failure in validating the length provided by an attacker-crafted CP2179 packet, Wireshark versions 2.0.0 through 4.0.7 is susceptible to a divide by zero allowing for a denial of service attack.

CVSS 6.5 · Medium · EPSS 2.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • wireshark

    Versions
    • ≥ 2.0.0, ≤ 4.0.7: Affected (semver)

    No fix published

  • wireshark Debian:12

    Versions
    • 4.0.10-1
    • 4.0.3-1
    • 4.0.5-1~exp1
    • 4.0.6-1
    • 4.0.6-1~deb12u1
    • 4.0.6-1~exp1
    • 4.0.7-1
    • 4.0.8-1
    Affected ranges
    • ECOSYSTEM: < 4.0.11-1~deb12u1

    Update to 4.0.11-1~deb12u1

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.0.8-1

    Update to 4.0.8-1

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.0.8-1

    Update to 4.0.8-1

  • wireshark Ubuntu:Pro:20.04:LTS

    Versions
    • 3.0.5-1
    • 3.0.7-1
    • 3.2.1-1
    • 3.2.2-1
    • 3.2.3-1
    • 3.2.3-1ubuntu0.1~esm1
    • 3.2.3-1ubuntu0.1~esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wireshark Ubuntu:Pro:22.04:LTS

    Versions
    • 3.4.7-1~exp1
    • 3.4.9-1
    • 3.6.2-1ubuntu1
    • 3.6.2-2
    • 3.6.2-2ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →