CVE-2023-29200
CVE-2023-29200 · contao/core-bundle has path traversal vulnerability in the file manager
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Contao is an open source content management system. Prior to versions 4.9.40, 4.13.21, and 5.1.4, logged in users can list arbitrary system files in the file manager by manipulating the Ajax request. However, it is not possible to read the contents of these files. Users should update to Contao 4.9.40, 4.13.21 or 5.1.4 to receive a patch. There are no known workarounds.
CVSS 4.3 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
contao
- Versions
- >= 2.0.0, < 4.9.40: Affected
- >= 4.10.0, < 4.13.21: Affected
- >= 5.0.0, < 5.1.4: Affected
No fix published
contao/contao Packagist
- Versions
- 4.9.0
- 4.9.1
- 4.9.10
- 4.9.11
- 4.9.12
- 4.9.13
- 4.9.14
- 4.9.15
- 4.9.16
- 4.9.17
- 4.9.18
- 4.9.19
- 4.9.2
- 4.9.20
- 4.9.21
- 4.9.22
- 4.9.23
- 4.9.24
- 4.9.25
- 4.9.26
- 4.9.27
- 4.9.28
- 4.9.29
- 4.9.3
- 4.9.30
- 4.9.31
- 4.9.32
- 4.9.33
- 4.9.34
- 4.9.35
- 4.9.36
- 4.9.37
- 4.9.38
- 4.9.39
- 4.9.4
- 4.9.5
- 4.9.6
- 4.9.7
- 4.9.8
- 4.9.9
- Affected ranges
- ECOSYSTEM: ≥ 4.9.0, < 4.9.40
Update to 4.9.40
contao/contao Packagist
- Versions
- 4.13.0
- 4.13.1
- 4.13.10
- 4.13.11
- 4.13.12
- 4.13.13
- 4.13.14
- 4.13.15
- 4.13.16
- 4.13.17
- 4.13.18
- 4.13.19
- 4.13.2
- 4.13.20
- 4.13.3
- 4.13.4
- 4.13.5
- 4.13.6
- 4.13.7
- 4.13.8
- 4.13.9
- Affected ranges
- ECOSYSTEM: ≥ 4.13.0, < 4.13.21
Update to 4.13.21
contao/contao Packagist
- Versions
- 5.1.0
- 5.1.1
- 5.1.2
- 5.1.3
- Affected ranges
- ECOSYSTEM: ≥ 5.1.0, < 5.1.4
Update to 5.1.4