CVE-2023-29337
CVE-2023-29337 · NuGet Client Remote Code Execution Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
NuGet Client Remote Code Execution Vulnerability
CVSS 7.1 · High · EPSS 1.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
nuget 6.2.3
- Versions
- ≥ 6.0.0, < 6.2.4: Affected (custom)
Update to 6.2.4
nuget 6.4.1
- Versions
- ≥ 6.0.0, < 6.4.2: Affected (custom)
Update to 6.4.2
nuget 6.5.0
- Versions
- ≥ 6.0.0, < 6.5.1: Affected (custom)
Update to 6.5.1
nuget 6.3.2
- Versions
- ≥ 6.0.0, < 6.3.3: Affected (custom)
Update to 6.3.3
nuget 6.0.4
- Versions
- ≥ 6.0.0, < 6.0.5: Affected (custom)
Update to 6.0.5
nuget 6.6.0
- Versions
- ≥ 6.0.0, < 6.6.0: Affected (custom)
Update to 6.6.0
nuget 5.11.4
- Versions
- ≥ 5.0.0, < 5.11.5: Affected (custom)
Update to 5.11.5
nuget Debian:12
- Versions
- 2.8.7+md510+dhx1-1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
dotnet6 Ubuntu:22.04:LTS
- Versions
- 6.0.108-0ubuntu1~22.04.1
- 6.0.109-0ubuntu1~22.04.1
- 6.0.110-0ubuntu1~22.04.1
- 6.0.111-0ubuntu1~22.04.1
- 6.0.113-0ubuntu1~22.04.1
- 6.0.116-0ubuntu1~22.04.1
- Affected ranges
- ECOSYSTEM: < 6.0.118-0ubuntu1~22.04.1
Update to 6.0.118-0ubuntu1~22.04.1
dotnet7 Ubuntu:22.04:LTS
- Versions
- 7.0.105-0ubuntu1~22.04.1
- Affected ranges
- ECOSYSTEM: < 7.0.107-0ubuntu1~22.04.1
Update to 7.0.107-0ubuntu1~22.04.1