CVE-2023-30776
CVE-2023-30776 · Apache Superset: Database connection password leak
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An authenticated user with specific data permissions could access database connections stored passwords by requesting a specific REST API. This issue affects Apache Superset version 1.3.0 up to 2.0.1.
CVSS 4.9 · Medium · EPSS 2.1% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache superset
- Versions
- ≥ 1.3.0, ≤ 2.0.1: Affected (semver)
No fix published
apache-superset PyPI
- Versions
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 2.0.0
- 2.0.1
- Affected ranges
- ECOSYSTEM: ≥ 1.3.0, < 2.1.0
Update to 2.1.0