CVE-2023-30837
CVE-2023-30837 · Vyper storage allocator overflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vyper is a pythonic smart contract language for the EVM. The storage allocator does not guard against allocation overflows in versions prior to 0.3.8. An attacker can overwrite the owner variable. This issue was fixed in version 0.3.8.
CVSS 7.5 · High · EPSS 0.7% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
vyper
- Versions
- < 0.3.8: Affected
No fix published
vyper PyPI
- Versions
- 0.1.0b1
- 0.1.0b10
- 0.1.0b11
- 0.1.0b12
- 0.1.0b13
- 0.1.0b14
- 0.1.0b15
- 0.1.0b16
- 0.1.0b17
- 0.1.0b2
- 0.1.0b3
- 0.1.0b4
- 0.1.0b5
- 0.1.0b6
- 0.1.0b7
- 0.1.0b8
- 0.1.0b9
- 0.2.1
- 0.2.10
- 0.2.11
- 0.2.12
- 0.2.13
- 0.2.14
- 0.2.15
- 0.2.16
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 0.2.8
- 0.2.9
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.3.6
- 0.3.7
- Affected ranges
- ECOSYSTEM: < 0.3.8
Update to 0.3.8
vyper PyPI
- Versions
- 0.1.0b1
- 0.1.0b10
- 0.1.0b11
- 0.1.0b12
- 0.1.0b13
- 0.1.0b14
- 0.1.0b15
- 0.1.0b16
- 0.1.0b17
- 0.1.0b2
- 0.1.0b3
- 0.1.0b4
- 0.1.0b5
- 0.1.0b6
- 0.1.0b7
- 0.1.0b8
- 0.1.0b9
- 0.2.1
- 0.2.10
- 0.2.11
- 0.2.12
- 0.2.13
- 0.2.14
- 0.2.15
- 0.2.16
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 0.2.8
- 0.2.9
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.3.6
- 0.3.7
- Affected ranges
- GIT: < 0bb7203b584e771b23536ba065a6efda457161bb
- ECOSYSTEM: < 0.3.8
Update to 0.3.8