CVE-2023-30838
CVE-2023-30838 · PrestaShop vulnerable to possible XSS injection through Validate::isCleanHTML method
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, the `ValidateCore::isCleanHTML()` method of Prestashop misses hijackable events which can lead to cross-site scripting (XSS) injection, allowed by the presence of pre-setup `@keyframes` methods. This XSS, which hijacks HTML attributes, can be triggered without any interaction by the visitor/administrator, which makes it as dangerous as a trivial XSS attack. Contrary to other attacks which target HTML attributes and are triggered without user interaction (such as onload / onerror which suffer from a very limited scope), this one can hijack every HTML element, which increases the danger due to a complete HTML elements scope. Versions 8.0.4 and 1.7.8.9 contain a fix for this issue.
CVSS 8.6 · High · EPSS 1.0% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
prestashop
- Versions
- >= 8.0.0, < 8.0.4: Affected
- < 1.7.8.9: Affected
No fix published
prestashop/prestashop Packagist
- Versions
- 8.0.0
- 8.0.1
- 8.0.2
- 8.0.3
- Affected ranges
- ECOSYSTEM: ≥ 8.0.0, < 8.0.4
Update to 8.0.4
prestashop/prestashop Packagist
- Versions
- 1.7.0.0
- 1.7.0.0-beta.1.0
- 1.7.0.0-beta.2.0
- 1.7.0.0-beta.3.0
- 1.7.0.0-beta.4.0
- 1.7.0.0-rc.0.0
- 1.7.0.0-rc.1.0
- 1.7.0.0-rc.2.0
- 1.7.0.1
- 1.7.0.2
- 1.7.0.3
- 1.7.0.4
- 1.7.0.5
- 1.7.0.6
- 1.7.1.0
- 1.7.1.1
- 1.7.1.2
- 1.7.2.0
- 1.7.2.0-rc.1.0
- 1.7.2.1
- 1.7.2.2
- 1.7.2.3
- 1.7.2.4
- 1.7.2.5
- 1.7.3.0
- 1.7.3.1
- 1.7.3.2
- 1.7.3.3
- 1.7.3.4
- 1.7.4.0
- 1.7.4.0-beta.1
- 1.7.4.1
- 1.7.4.2
- 1.7.4.3
- 1.7.4.4
- 1.7.5.0
- 1.7.5.0-beta.1
- 1.7.5.0-rc.1
- 1.7.5.1
- 1.7.5.2
- 1.7.6.0
- 1.7.6.0-beta.1
- 1.7.6.0-rc.1
- 1.7.6.0-rc.2
- 1.7.6.1
- 1.7.6.2
- 1.7.6.3
- 1.7.6.4
- 1.7.6.5
- 1.7.6.6
- 1.7.6.7
- 1.7.6.8
- 1.7.6.9
- 1.7.7.0
- 1.7.7.0-beta.1
- 1.7.7.0-beta.2
- 1.7.7.0-rc.1
- 1.7.7.1
- 1.7.7.2
- 1.7.7.3
- 1.7.7.4
- 1.7.7.5
- 1.7.7.6
- 1.7.7.7
- 1.7.7.8
- 1.7.8.0
- 1.7.8.0-beta.1
- 1.7.8.0-rc.1
- 1.7.8.1
- 1.7.8.2
- 1.7.8.3
- 1.7.8.4
- 1.7.8.5
- 1.7.8.6
- 1.7.8.7
- 1.7.8.8
- Affected ranges
- ECOSYSTEM: < 1.7.8.9
Update to 1.7.8.9
Original sources
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-fh7r-996q-gvcp
- https://github.com/PrestaShop/PrestaShop/commit/46408ae4b02f3b8b1bb6e9dc63af5bcd858abd9c
- https://github.com/PrestaShop/PrestaShop/commit/dc682192df0e4b0d656a8e645b29ca1b9dbe3693
- https://nvd.nist.gov/vuln/detail/CVE-2023-30838