CVE-2023-31146
CVE-2023-31146 · Vyper vulnerable to OOB DynArray access when array is on both LHS and RHS of an assignment
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, during codegen, the length word of a dynarray is written before the data, which can result in out-of-bounds array access in the case where the dynarray is on both the lhs and rhs of an assignment. The issue can cause data corruption across call frames. The expected behavior is to revert due to out-of-bounds array access. Version 0.3.8 contains a patch for this issue.
CVSS 7.5 · High · EPSS 1.2% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
vyper
- Versions
- < 0.3.8: Affected
No fix published
vyper PyPI
- Versions
- 0.1.0b1
- 0.1.0b10
- 0.1.0b11
- 0.1.0b12
- 0.1.0b13
- 0.1.0b14
- 0.1.0b15
- 0.1.0b16
- 0.1.0b17
- 0.1.0b2
- 0.1.0b3
- 0.1.0b4
- 0.1.0b5
- 0.1.0b6
- 0.1.0b7
- 0.1.0b8
- 0.1.0b9
- 0.2.1
- 0.2.10
- 0.2.11
- 0.2.12
- 0.2.13
- 0.2.14
- 0.2.15
- 0.2.16
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 0.2.8
- 0.2.9
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.3.6
- 0.3.7
- Affected ranges
- ECOSYSTEM: < 0.3.8
Update to 0.3.8
vyper PyPI
- Versions
- 0.1.0b1
- 0.1.0b10
- 0.1.0b11
- 0.1.0b12
- 0.1.0b13
- 0.1.0b14
- 0.1.0b15
- 0.1.0b16
- 0.1.0b17
- 0.1.0b2
- 0.1.0b3
- 0.1.0b4
- 0.1.0b5
- 0.1.0b6
- 0.1.0b7
- 0.1.0b8
- 0.1.0b9
- 0.2.1
- 0.2.10
- 0.2.11
- 0.2.12
- 0.2.13
- 0.2.14
- 0.2.15
- 0.2.16
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 0.2.8
- 0.2.9
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.3.5
- 0.3.6
- 0.3.7
- Affected ranges
- GIT: < 4f8289a81206f767df1900ac48f485d90fc87edb
- ECOSYSTEM: < 0.3.8
Update to 0.3.8