CVE-2023-31419
CVE-2023-31419 · Elasticsearch StackOverflow vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was discovered in Elasticsearch, affecting the _search API that allowed a specially crafted query string to cause a Stack Overflow and ultimately a Denial of Service.
CVSS 6.5 · Medium · EPSS 61.1% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
elasticsearch
- Versions
- ≥ 7.0.0, < 7.17.12: Affected (semver)
- ≥ 8.0.0, < 8.9.0: Affected (semver)
Update to 7.17.12; Update to 8.9.0
elasticsearch Ubuntu:16.04:LTS
- Versions
- 1.6.2+dfsg-1
- 1.7.3+dfsg-1
- 1.7.3+dfsg-2
- 1.7.3+dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published