CVE-2023-31669
CVE-2023-31669
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@' before a quote (").
CVSS 5.5 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wabt Debian:12
- Versions
- 1.0.32-1
- 1.0.33-1
- 1.0.34+dsfg+~cs1.0.32-1
- 1.0.34+dsfg2+~cs1.0.32-1
- 1.0.34+dsfg2+~cs1.0.32-2
- 1.0.34+dsfg2+~cs1.0.32-3
- 1.0.34+dsfg2+~cs1.0.32-4
- 1.0.34-1
- 1.0.36+dfsg+~cs1.0.36-1
- 1.0.36+dfsg+~cs1.0.36-2
- 1.0.41+dfsg+~cs1.0.39-1
- 1.0.41+dfsg+~cs1.0.39-2
- 1.0.42+dfsg+~cs1.0.39-1
- 1.0.42+dfsg+~cs1.0.39-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wabt Debian:13
- Affected ranges
- ECOSYSTEM: < 1.0.33-1
Update to 1.0.33-1
wabt Debian:14
- Affected ranges
- ECOSYSTEM: < 1.0.33-1
Update to 1.0.33-1
wabt Ubuntu:20.04:LTS
- Versions
- 1.0.11-1
- 1.0.12-1
- 1.0.13-1
- 1.0.13-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wabt Ubuntu:22.04:LTS
- Versions
- 1.0.20-1
- 1.0.24-1
- 1.0.24-2
- 1.0.25-1
- 1.0.26-1
- 1.0.27-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published