CVE-2023-31670
CVE-2023-31670
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue in wasm2c 1.0.32, wasm2wat 1.0.32, wasm-decompile 1.0.32, and wasm-validate 1.0.32 allows attackers to cause a Denial of Service (DoS) via running a crafted binary.
CVSS 7.5 · High · EPSS 0.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wabt Debian:12
- Versions
- 1.0.32-1
- 1.0.33-1
- 1.0.34+dsfg+~cs1.0.32-1
- 1.0.34+dsfg2+~cs1.0.32-1
- 1.0.34+dsfg2+~cs1.0.32-2
- 1.0.34+dsfg2+~cs1.0.32-3
- 1.0.34+dsfg2+~cs1.0.32-4
- 1.0.34-1
- 1.0.36+dfsg+~cs1.0.36-1
- 1.0.36+dfsg+~cs1.0.36-2
- 1.0.41+dfsg+~cs1.0.39-1
- 1.0.41+dfsg+~cs1.0.39-2
- 1.0.42+dfsg+~cs1.0.39-1
- 1.0.42+dfsg+~cs1.0.39-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wabt Debian:13
- Affected ranges
- ECOSYSTEM: < 1.0.33-1
Update to 1.0.33-1
wabt Debian:14
- Affected ranges
- ECOSYSTEM: < 1.0.33-1
Update to 1.0.33-1