p PatchFirst

CVE-2023-32004

CVE-2023-32004

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability has been discovered in Node.js version 20, specifically within the experimental permission model. This flaw relates to improper handling of Buffers in file system APIs causing a traversal path to bypass when verifying file permissions. This vulnerability affects all users using the experimental permission model in Node.js 20. Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

CVSS 8.8 · High · EPSS 2.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • node.js

    Versions
    • ≥ 4.0, < 4.*: Affected (semver)
    • ≥ 5.0, < 5.*: Affected (semver)
    • ≥ 6.0, < 6.*: Affected (semver)
    • ≥ 7.0, < 7.*: Affected (semver)
    • ≥ 8.0, < 8.*: Affected (semver)
    • ≥ 9.0, < 9.*: Affected (semver)
    • ≥ 10.0, < 10.*: Affected (semver)
    • ≥ 11.0, < 11.*: Affected (semver)
    • ≥ 12.0, < 12.*: Affected (semver)
    • ≥ 13.0, < 13.*: Affected (semver)
    • ≥ 14.0, < 14.*: Affected (semver)
    • ≥ 15.0, < 15.*: Affected (semver)
    • ≥ 17.0, < 17.*: Affected (semver)
    • ≥ 19.0, < 19.*: Affected (semver)
    • ≥ 20.0, < 20.5.1: Affected (semver)

    Update to 20.5.1

Original sources

Check your server →